problem with Python console

OS X 10.7, pycharm 1.5.3

Python Console does not work. I am sure it did in earlier versions, but I have not been using pycharm (or python) for a few months, so do not know when and how it broke. Also I cannot be sure that it ever did work on my machine.

slightly more detailed information:

It starts by displaying eg

/System/Library/Frameworks/Python.framework/Versions/2.7/bin/python -u /Applications/PyCharm 1.5.3.app/helpers/pydev/console/pydevconsole.py 53440 53441

then, looking at the firewall logs, I see things like

pycharm is listening from ::ffff:0.0.0.0:53441 proto=6

Python is listening from 127.0.0.1:53440 proto=6

but nothing else happens and eventually I get

Couldn't connect to console process.

Process finished with exit code 137

I have tried with Python 2.6, 2.7 and 3.1, and the same happens.

Any suggestions for further troubleshooting?

Thanks

3 comments
Comment actions Permalink

I forgot to add that checking ~/Library/Logs/PyCharm10/idea.log, I have things like

2011-07-25 00:23:35,218 [3253188]   INFO - .httpclient.HttpMethodDirector - I/O exception (java.net.ConnectException) caught when processing request: Connection refused

2011-07-25 00:23:35,218 [3253188]   INFO - .httpclient.HttpMethodDirector - Retrying request

etc
0
Comment actions Permalink

One more data point: If I switch my wifi off, everything is fine (even if I am connected via ethernet). So, perhaps this is not directly related to pycharm, but perhaps it is (I have never noticed anything like this before). Does anybody have any ideas here?

0
Comment actions Permalink

For those stubmled upon the same problem:

http://youtrack.jetbrains.com/issue/PY-7070 .

0

Please sign in to leave a comment.