SVN 1.7

Hi all,

Just a line to say it appears that EAP2 doesnt yet support svn1.7, so hold off updating! :-)

-Si

1 comment

PyCharm doesn't use SVN directly, it uses Subversion protocol via SvnKit Java library. SVN 1.7 should be backwards compatible with older clients if you are using working copies of the compatible format.

Regarding SVN 1.7 features support refer to: http://youtrack.jetbrains.net/issue/IDEA-70517. It means that you can use 1.7 SVN servers, but can't use working copies that were checked out with new SVN clients until at least http://youtrack.jetbrains.net/issue/IDEA-72400 is addressed.

It may take some time until full SVN 1.7 support is implemented in SvnKit and bundled with PyCharm and other IntelliJ IDEA based products, so your holding off could last for months.

0

Please sign in to leave a comment.