Remote debugging + remote interpreter not working

I configured a remote interpreter and have some local sources.  But when I configure/debug a test (with target /Users/yang/.../test_foo.py), I see that the remote ssh command isn't able to file this local path:

ERROR: file not found: /Users/yang/.../test_foo.py

Why's it looking for the local path on the remote server?  Do I need to manually run rsync or something to copy the sources to the remote server first before every debug session?
5 comments
Comment actions Permalink
You need to configure Deployment: http://www.jetbrains.com/pycharm/webhelp/deployment.html.
There is an option to upload files automatically on save.
0
Comment actions Permalink
I configured the deployment (tested that the connection works) and enabled "Always" upload but I see nothing happening, no files are in the specified remote dir, and trying to run a test results in:

ERROR: file not found: /tmp/pycharm-test-deploy/.../test_foo.py
0
Comment actions Permalink
Enable this option: http://img10.imageshack.us/img10/7302/cqy0.png . Make changes to a file, save it.
To synchronize local files to the remote server for the first time refer to http://www.jetbrains.com/pycharm/webhelp/uploading-and-downloading-files.html .

Double check that mappings are configured correctly in the Deployment configuration, otherwise your files will end up in a wrong folder.
0
Comment actions Permalink
I'm having this same problem.  
I try to set a breakpoint in the debugger and it is looking in my local path for files that it should be looking in the remote path.  It seems to be skipping the whole look down the path thing.
0
Comment actions Permalink
I seemed to have solved my problem by verifying that both the local and remote paths end with a '/'.
0

Please sign in to leave a comment.