Open in browser missing

I've imported my project into PyCharm but when I right click on an html file the "Open in browser" option doesn't show.

For different projects it does show on html files. How do I get that option back?
10 comments
Comment actions Permalink
FYI, got a response from support:

Hi,
Thanks for your feedback.

It's the known issue https://youtrack.jetbrains.com/issue/PY-13986, please follow it for updates. See http://intellij-support.jetbrains.com/entries/23368682 if you are not familiar with YouTrack.


PyCharm team.
0
Comment actions Permalink

This is still an issue, 4 years later... all the menu options mentioned in the help pages about viewing an .html file in a browser are AWOL.  The best workaround I can do is "View in Finder" and then double-click from there.

0
Comment actions Permalink

I had the same problem when I installed a new version of the program. Also in HTML files did not work Ctrl + / (comment line). The solution was looking for a long time in the settings but it was simple:

In settings - > editor - > file types - > HTML, in the list of registered patterns was not "*.html ", but it was in Stelve Html Components. I added"*.html " in HTML and everything worked.

Maybe this will help you.

0
Comment actions Permalink

Hi Cekcctac,

This is actually unusual that you had *.html assigned to a different file type. Did you make a fresh installation of PyCharm or updated?

0
Comment actions Permalink

I use Linux mint 18. I had installed version 2016. I installed the new version via Snap as stated in the installation instructions. take me worth the new and old version, old everything works And the new did not work.

0
Comment actions Permalink

Did you import settings from old one to new one?
I suspect there is some custom plugin causing the issue.

0
Comment actions Permalink

No, I didn’t import the old settings. What plugins didn’t set the plugin’s ses settings as standard. But for the sake of experiment, I imported the old settings, but this problem did not solve. I also suspected that some plug-in was installed and it interferes with normal operation, but I did not know how to define this plug-in.

0
Comment actions Permalink

Cekcctac,

THANK YOU for your info on this. I have had the same issue for a few months now and it's been driving me crazy. Everything worked completely fine with the open in browser and it showed the browser icon shortcuts when I hovered over html code, then it suddenly STOPPED working. The option to open in browsers just disappeared completely. It was driving me crazy. 

I did exactly what you said, and yup my .html was somehow also assigned to Svelte Html Components. I don't know what that even is or how it happened. I hadn't made any changes to my system other than updating IntelliJ when it prompted me to.

Anyways, THANK YOU for providing the fix. I was ready to give up and move to a different IDE.

0
Comment actions Permalink

Forgot to add, I was using regular IntelliJ Ultimate, not PyCharm. This still fixed my issue. I hadn't installed any new plug-ins etc when the issue started.

0
Comment actions Permalink

I nice to help you) I understand you, I also installed the previous version because this option was very important to me. I hope the developers will fix this minor problem in our favorite program)

0

Please sign in to leave a comment.