pycharm removes whitespaces?

Answered
Hi,
I've got dictionary in my code. For it to conform with pylint of the project, I need whitespaces after every element, like

dictionary = {
    'key':value,[whitespace should be here]
    'key':value,
}

The thing is, when I add those whitespaces and hit crtl-s, they disappear. I was looking through the settings, searching by "spaces" keyword, but I've found only highlighting option, nothing that would change or delete them for me.

Any ideas what this might be?

Thanks
Greg
3 comments
Comment actions Permalink
Try Settings -> Editor -> Strip trailing spaces on save ('Other' section) -> None.
1
Comment actions Permalink

Hi, I don't think the above solution works anymore, as I cannot find Strip trailing spaces on save ('Other' section) -> None

0
Comment actions Permalink

Hi,
It is now under Settings/Preferences | Editor | General --> Other.

You can just search the settings:

1

Please sign in to leave a comment.