How to resolve PuTTY Fatal Error after upgrading from PyCharm 4.0.4 to 4.0.6

Answered
I just upgraded to PyCharm 4.0.6 and now I keep getting a periodic dialog box saying, "PuTTY Fatal Error Disconnected: No supported authentication methods available (server sent: publickey)".

This dialog appears twice each time the auto upload is triggered to the staging server.

Everything was working fine before the upgrade.
5 comments
Comment actions Permalink

I've got the similar issue with PhpStorm. The message appears periodically and I can't bind it with any thing. Can somebody give a hint how to solve this issue. I'm using windows 10, PhpStorm 2016.2.1 Build #PS-162.1447.5 

Thank you in advance. 

1
Comment actions Permalink

In my case, I was getting this message because PHPstorm was "Checking incoming and outgoing changes" with a now non-existent Mercurial repository. I eventually fixed it by deleting the bad repository reference in my project's mercurial configuration file. You can also just disable automatic VC change checks entirely (link).

 

 

0
Comment actions Permalink

This is actually an issue with putty in general. I have had the same issue for a few days and I decided to break down and solve it. 

First, my issue revolves around mounted share drives that I access from my Windows 10 system. U: drive is a Mercurial repository on a Linux VM. When I open it as a project in PHPStorm, it works fine (except for the normal complaint about watching files on a network drive). Intermittently, PHPStorm will attempt to check for changes. Here's where the putty error's come into play, and I think that this is probably a rare situation that only happens with certain setups. Mine goes something like that. The Mercurial repository was checked out using ssh, but that SSH checked occurred from my VM where I have my private ssh keys added. On my Windows machine, I don't have those private keys. They were actually created for that project alone. So PHPStorm is trying to use Putty SSH to check the Mercurial project for changes and since my local Windows host machine doesn't have the SSH keys for the repository. 

My easiest answer was to fetch the private key from the VM and add it to Pageant (Putty's Key Manager) locally. In order to do this, you'll have to use PuttyGen to generate a Putty-specific private key file based on your openssh key. The resulting PPK needs to be added to Pageant. Another step that you may need to do (I'm unsure if it was necessary because I did it before I had the complete solution) is to create a new putty connection with your repo remote (in my case Bitbucket.org) and try to connect using your new ppk. This may be necessary to add the remote keys or information about the remote. You should only need to try this if you've done everything else here and it still doesn't work.

There may be other situations where this putty error occurs, but for me this was the problem/fix. It's basically complaining that Putty can't connect to the remote repository because it's missing the key. So if you are getting this error and you want to use version control to show changes within the IDE, then you need to add the correct private key to Windows, specifically Pageant, and you'll need to use Putty's key generator/converter to create a compatible key. I hope this helps someone.

0
Comment actions Permalink

Same problem with PHPStorm.

Where to disable IDE autoconnect attempts?

In my case repository is behind of VPN connection (that is not always connected, of course). And, this "can not connect" messages es very annoying!

0
Comment actions Permalink

Dear all,

please feel free to vote for https://youtrack.jetbrains.com/issue/IDEA-208176 and https://youtrack.jetbrains.com/issue/IDEA-139034

I'm sorry for the inconvenience.

0

Please sign in to leave a comment.