Failed to load remote gems http://gems.rubyonrails.org

The following notification keeps popping up:

Failed to load remote gems http://gems.rubyonrails.org
(Gem::RemoteFetcher::FetchError)
bad response Not Found 404 (http://gems.rubyonrails.org/prerelease_specs.4.8.gz)

Please check proxy settings and gem urls

Has any one else seen similar?

I don't use a proxy server and the settings aren't set to use one. I've added http://gems.rubyonrails.org to my gem sources with the following:

gem sources -a http://gems.rubyonrails.org


but it keeps popping up any ideas, anyone?

--
Taine
50 comments
Comment actions Permalink

I did two things at once - deleted the http://gems.rubyonrails.org/ from the source list and downloaded and installed RM 3.2.2

Now I only get two pink messages.

I also see another discussion topic that focuses on the Stackoverflow diagnostic.

Bob G

0
Comment actions Permalink

Same issue here, I'm getting 3 pink error messages when I open a (Ruby 1.9.2) project. This is with RM 3.2.2. I also use rvm.



Attachment(s):
Screen shot 2011-07-22 at 9.37.30 AM.png
0
Comment actions Permalink

I got 2 of the 3 warnings to go away by typing

rvm rubygems current

rvm rubygems remove

The spec_fetcher.rb error remains but that is a bug.

I closed RubyMine before running the rvm commands then reopened and that fixed the rubygem URL issues.

I am running 3.2.2 on Lion.

0
Comment actions Permalink

@David - Thank you for that tidbit. If you wouldn't mind, where did you run the "rvm" commands? You say that RubyMine was closed, so did you open a command window? Is there a particular directory (C:\ruby192\bin or C:\Program Files\JetBrains\RubyMine 3.2.1\bin?) that you have to be in to make it work? I'm very new to RubyMine (love it, btw) so thank you for the help.

0
Comment actions Permalink

Sorry, I forgot that not everyone uses rvm, the ruby version manager. It runs in Bash so may not work in windows unless you have installed a unix emulator command shell.

0
Comment actions Permalink

What does that effectively do, by the way. it looks like I'm removing all my rubygems.
I'm just a bit worried that a general piece of advice, like that, for a specific problem with no underlying explanation seems pretty dangerous.

0
Comment actions Permalink

Could we get a resolution to this issue?

I am getting the same pink warnings and I just downloaded the latest version Rubymine 3.2.2 using RVM 1.9.2 on Mac OSX 10.6



Attachment(s):
Screen shot 2011-07-25 at 5.20.59 PM.png
0
Comment actions Permalink

You are proberly running a old gem version. Close RubyMine and try this in your console

gem update --system

0
Comment actions Permalink

Thanks a lot!! FIXED!!! :):):):)

0
Comment actions Permalink

Thank you, Lasse. That was an easy fix.

For anyone else trying this, there are two hypens before "system". Not sure why, but that was hard to see in email and it doesn't work with just one. Also, the console in the Command Prompt.

This feels like something that should either be done automatically in the background or there should be some sort of prompt. It seems like a number of people have been tripped up by this, so that might be something for RubyMine to consider. Without this forum post I'm pretty sure that I would never have been able to figure it out, so thanks again!

0
Comment actions Permalink

That did the trick alright. Of course I'd tried that before.  This GEM version out just recently I'm sure.

0
Comment actions Permalink

Yes, I did the gem update and also loaded RM 3.2.2 build 186. No pink messages.

0
Comment actions Permalink

sorry, nothing to look at here...posted in wrong thread and can't figure out how to delete.

0
Comment actions Permalink

Thanks Lasse that worked!:)

0
Comment actions Permalink

+1

gem update --system

saves the day.

0
Comment actions Permalink

mcramer wrote:

Thank you, Lasse. That was an easy fix.

For anyone else trying this, there are two hypens before "system". Not sure why, but that was hard to see in email and it doesn't work with just one. Also, the console in the Command Prompt.

This feels like something that should either be done automatically in the background or there should be some sort of prompt. It seems like a number of people have been tripped up by this, so that might be something for RubyMine to consider. Without this forum post I'm pretty sure that I would never have been able to figure it out, so thanks again!


mcramer,
  The reason for the two dashes: that's how linux/bash works. one dash for one letter only.

ls -s


two dashes for more than one letter

ls --size



An error capturing prompt would be nice ..."Please run gem update --system" to fix this problem.

my 2 cents

Eric

0
Comment actions Permalink

I was excited to find the 'gem update --session' solution right up until I ran it on my Ubuntu 11.10 system and got the following:

gem update --system is disabled on Debian, because it will overwrite the content of the rubygems Debian package, and might break your Debian system in subtle ways. The Debian-supported way to update rubygems is through apt-get, using Debian official repositories.
If you really know what you are doing, you can still update rubygems by setting the REALLY_GEM_UPDATE_SYSTEM environment variable, but please remember that this is completely unsupported by Debian.

Are there anyother Ubuntu users out there that my have found a solution for us?

0
Comment actions Permalink

My advice would be to apt-get uninstall rubgems (or whatever it is called in Debian/UIbuntu land).

I do recall a few months back the RubyGems Debian maintainer quiting.

Personally, I always install RubyGems from source on Ubunutu/Debian. Never had this problem since I've started doing that.

HTH

0
Comment actions Permalink

I do use Ubuntu 11.04, I have not upgraded yet. But my first guess is that you are not using RVM to manage your ruby versions. Are you using RVM, or are you using ubntu's ruby packages?

0
Comment actions Permalink

If you're on Lion, this solution may help.
If you're on Lion and have been using the Ruby 3 Tutorial to get started, this is very likely to help.

workaround:
1) In the menu, open RubyMine >> Preferences
2) Select Ruby SDK and Gems under Project Settings

3) Is your Ruby Interpreter for the current project set to 1.8.7?
If so, switch it to whichever 1.9.2 option you prefer.
4) Click "OK", then exit RubyMine.

result:
This got rid of the failures that kept appearning when opening a Rails app under RubyMine.

FYI - I recall reading that Ruby 1.8.7 has an open compatibility bug with Mac OS X Lion.
Since I'm working entirely in Rails 3, this fix works well for me.

If you need to work in 1.8.7,
I suggest trying this fix first for a new Ruby 1.9.2 + Rails 3 project. If it works, then focus on fixing compatibility between Ruby 1.8.7 + Rails 2 and
Mac OS X 10.7.x

Does this fix work for you?

0

Please sign in to leave a comment.