db:migrate error

Hi,

I am an absolute beginner on RoR and RubyMine. Have run into an issue trying the exercises in "Agile Web Development with Rails". Can someone please help me with ideas/suggestion to overcome this?

Command executed: rake db:migrate

---------------------------------------------------------------------------------

C:\Ruby\Ruby192\bin\ruby.exe -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) C:\Ruby\Ruby192\bin\rake db:migrate
rake aborted!
You have already activated rake 0.9.0.beta.1, but your Gemfile requires rake 0.8.7. Consider using bundle exec.


(See full trace by running task with --trace)


Process finished with exit code 1

---------------------------------------------------------------------------------
I get the same result in both RubyMine and cmd prompt.


OS: Windows XP
RM ver.: 3.1
Ruby/Gem versions:
E:\ruby -v
ruby 1.9.2p136 (2010-12-25) [i386-mingw32]


E:\gem --version
1.3.7

Thanks and regards,

Ravi

2 comments
Comment actions Permalink

gem uninstall rake --version 0.9.0.beta.1
gem install rake --version 0.8.7


If you are using RubyInstaller distribution, make sure you don't have RUBY\lib\ruby\gems\1.9.1\specifications\rake.gemspec file.

Or you can just update rake version in the Gemfile.rb file.

0
Comment actions Permalink

Hi Serge,

Thanks for your response, solved the problem. Appreciate your help.


Thanks and regards,

Ravi

0

Please sign in to leave a comment.