RubyMine Not Registering

Hi All,

I have download RubyMine for Mac from JetBrains Website. When I launch the Application, it displays the Registration Dialog. After I enter the Registration Information and click the OK Button, the Registration Dialog disappears and nothing happens.

I have tried entering the License Key with and without the following:
===== LICENSE BEGIN =====
===== LICENSE END =====

None of the options has worked so far.

Are there some specific instructions in order to perform the registration.

Looking forward to your replies.

Thanks and Regards,

Muhammad Haseeb Khan

5 comments
Comment actions Permalink

Please provide the log from ~/Library/Logs/RubyMineXX directory. This issue may be related to the networking configuration and RM may be trying to contact the license server. Try to wait for several minutes. If the process is not running, then there must be some Mac specific issue. What Java versions do you have installed? What's your OS X version?

0
Comment actions Permalink

I'm experiencing the same problem.  No matter how I enter my key (w/ whitespace, with header and footer, with new lines), I cannot get RubyMine to fill in the OK button.  Waiting a long time changes nothing, neither does restarting RM.

I'm using: Ubuntu 10.4  Java 1.6.0_22


idea.log is the only file in .RubyMine31/system/logs:

2011-02-17 10:39:50,550 [      0]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDEA STARTED ------------------------------------------------------
~                                                                                               
~                                                                                               
~                             

0
Comment actions Permalink

You problem is different, if OK button is not enabled, it means the either user name or licence key is incorrect.

0
Comment actions Permalink

Well, thanks, I found what was wrong.  user name = company name, but with the Inc

That's a ridiculous way to waste a half an hour.  Why no error message - "user name / key don't match" or "user name not valid"?

0
Comment actions Permalink

Sorry for the inconvenience, I've submitted an issue for this: http://youtrack.jetbrains.net/issue/IDEA-65670 .

0

Please sign in to leave a comment.