Find in Path results - screen corruption with OpenJDK

Hi,

Not sure if this is a bug in IntelliJ or in OpenJDK.

I'm running v15.0.1, build 143-382 on Debian 'testing'. When I run it using OpenJDK 1.7.0_91 or 1.8.0_72-internal (both installed from the 'testing' repo packages), the Find in Path results get corrupted on the screen when you move the focus aroud the results items, either by clicking or using the keyboard arrows. Sometimes a row in that view becomes blank, sometimes it gets partially overwritten with text from other rows. It's as if the redraw on focus changes is messed up somehow. Attached is a screenshot that shows an example of the corruption.

This does NOT happen when I run it with Oracle JDKs 1.7.0_79 or 1.8.0_66.

Just thought I'd post this here, as I haven't found any info about this issue by searching the bugs and forums or by googling.



Attachment(s):
find_in_path_screen_corruption.png
2 comments
Comment actions Permalink

Yes! Glad to know someone else experienced it too.

The above problem with Find in Path only happens with OpenJDK, BUT I do get similar rendering problems when using Switcher (ctrl-tab) with the Oracle JDK 1.8.0_66: as I hit ctrl-tab multiple times in a row to cycle through the list of open files, I get similar rendering problems, with blank or duplicated rows.

0

Please sign in to leave a comment.