No default folders created in new gradle project

Answered

I am following instructions at https://www.jetbrains.com/idea/help/creating-a-gradle-project.html to create a new gradle project. Before I can specify the gradle settings, a window opens where I am asked to fill in a groupID and an artefactId. This step is not in the description I linked. After I fill in the groupId and artefactId I can proceed to the next window where I check "Create directories for empty content roots automatically". However, this doesn't seem to acomplish anything. The project is created without the default folders 'src/main/java' etc. Did I miss some general settings or did I do something wrong during creation?

PS: I am using Intellij Idea 15, Linux version

8 comments

I'm having the same issue, tried a bunch of things to resolve it but nothing seems to work. I'm using:

IntelliJ IDEA 2016.1.2
Build #IU-145.971, built on April 29, 2016
JRE: 1.8.0_76-release-b162 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

Running on OSX 10.11.14 with Gradle v2.14 installed via homebrew. 

0

People said that there is an option to create the folders:

But here I just get:

 

What is wrong here?

IntelliJ IDEA 2017.2.5
Build #IC-172.4343.14, built on September 26, 2017
JRE: 1.8.0_152-release-915-b12 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 8.1 6.3

0

It is under Gradle project settings (File | Settings | Build, Execution, Deployment | Build Tools | Gradle -> Create directories for empty content roots):

3

After I checked "Create directories for empty content roots" in Gradle project settings, folders didn't appear.

0

I recently upgraded 2018.01 version. My earlier version of Intellij used to prompt for to create directories for empty content roots automatically while creating a new Project but this version does not. Is there anyway i can make the newer version prompt for
Thank you !!

0

Please sign in to leave a comment.