Scanning Files to Index hangs

Answered

Yesterday when working in Intellij IDEA (version 14.1.5) on Mac, I noticed that scanning files (caching) would not terminate. In addition, I got a popup saying something about intellij running out of memory, but I chose the shutdown option. Restarting intellij did not work.

I have 11 packages in my project, and this has not happened to me before. I am mounting my project from an external drive. So if I add a new package it will take a while to scan the package at first but afterwards it should be fine.

The most common suggestion I got from researching this issue was to invalidate my caches and restart IntelliJ. This did not work.

I checked my logs and I saw the following entry upon opening Intellij:

2015-10-07 09:12:13,754 [ 179436]  ERROR - wvfs.impl.VirtualDirectoryImpl - PersistentFS returned duplicate file names(Stipple,stipple) ignoreCase: true SystemInfo.isFileSystemCaseSensitive: false SystemInfo.OS: Mac OS X 10.10.5 wasChildrenLoaded: false in the dir: …

Looking this issue up, apparently I had to add the following to idea.properties:

idea.case.sensitive.fs=true


This also did not resolve my issue.

Since this process is still going, I cannot debug using intellij. Has anyone else encountered this issue? If so, how did you resolve this?

Also, how long does it normally take to cache a (relatively) large project?

Thanks!

12 comments
Comment actions Permalink

Please file a bug at http://youtrack.jetbrains.com/issues/IDEA and attach all the relevant idea.log files to it.

0
Comment actions Permalink

Is this solved ? Because am using the latest version of intellij (couldnt find the version) and am facing this issue of "scanning files to index" because my code is imported from network shares . 

 

Thanks 

0
Comment actions Permalink

I too am having this issue--in PyCharmCE 2017.2.3 on Mac OS 10.12.6 "Sierra"--which is preventing "activation" of almost all of the Run menu (all but the Toggle Line Breakpoint, Toggle Temporary Line Breakpoint, and View Breakpoints Run-menu commands are greyed-out), with the eventual appearance of the out of memory popup.  What gives: (why) isn't there some way to (at least) pause this process, (if not kill it outright)?  Thanks!

0
Comment actions Permalink

By slowing the editor to a crawl, this problem is rendering the IDE basically unusable!

0
Comment actions Permalink

And it always ends up crashing!  Not good!

0
Comment actions Permalink

The best way for me to remedy this issue was:

1. Limit the number of packages I have in a project (at the time I had 12 packages),

2. Keep packages small in size (I had several packages with 100s of files), and

3. Keep project files stored on disk rather than over the network.

0
Comment actions Permalink

This happens to me too. The message at bottom says "Scanning files to index..." and the application freezes for a long time and then eventually crashes. My version of Webstorm is: WebStorm 2017.1.4, build WS-171.4694.29

 

Thanks,

Casey

 

0
Comment actions Permalink

I am having same Issue. My IntelliJ 14 was working fine but suddenly message at bottom says "Scanning files to index..." and the application freezes for a long time and then eventually crashes.

0
Comment actions Permalink

Are there any auto-generated files in your project? If so, IDEA would reindex them every time.

If you have a huge project, maybe allocating more heap to IDEA process would help:
https://intellij-support.jetbrains.com/hc/en-us/articles/206544869

0
Comment actions Permalink

Hi Pert, Thanks for reply, If this is the case then why it was working earlier and suddenly It is creating a problem. 

0
Comment actions Permalink

Have you changed anything in IDE settings? Maybe you have added some third party plugins recently? Please try turning off all third party plugins and invalidating caches (File | Invalidate cache).

0

Please sign in to leave a comment.