Maven project shows very often code in red

I am using idea ultimate 14.1.2

I have seen this problem before I guess, but very rarely and nothing the Maven projects > Reimport all maven projects couldn't solve.

Now I am getting this very, very often. The project builds just fine in maven, however idea shows whatever code/page I open in red. the above action as wel las synchronize whole project also won't do much.

There are many entries similar to this in idea's log file:

java.lang.RuntimeException: org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
[FATAL] Non-resolvable parent POM

The only workaround is to restart the ide (no need to invalidate its cache).

Is there another, perhaps faster way to sovle this?

thanks,
john

3 comments
Comment actions Permalink

Try 14.1.3 release.

If it doesn't help, please submit a bug at http://youtrack.jetbrains.com/issues/IDEA with idea.log (https://intellij-support.jetbrains.com/entries/23352446) and a sample project to reproduce the problem.

0
Comment actions Permalink

thanks, I think the new version came just in time. will update this post soon, hopefully to say it worked.

0
Comment actions Permalink

I have tried 14.1.3 since. I thought it was really fixed as, for more than a week, switching between project and git branches, no maven issue (from Idea). Until now. The only maybe unusual thing, I have kept a tag branch checked out for the duration of the weekend, then switched to develop this morning. I have done a mvn clean install then attempted to open the very first class, which happened to be a junit test. I have, of course, synchronized project, and mvn reimported all projects. I have also manually updated/reindexed local mvn repository, in idea's settings.

What shows in red: local dependencies only, meaning local to the project in use. For instance, methods specific to java.util such as a SortedSet in this case are fine. The junit's assertEquals, statically imported shows fine too. Any class/method outside the scope of this class, which are dependencies of my module, defined in other modules in same project show in red and code doesn't compile (in intellij, otherwise, mvn in console mode is ok).

I won't submit a sample project since this issue seems to happen quite randomly. However, if I can ever find a mean to reproduce this more often will surely let you know.

0

Please sign in to leave a comment.