JavaScript debugger: NS_ERROR_NOT_AVAILABLE

Having failed getting Firefox to connect to IntelliJ, I started the debugging session from IntelliJ which starts Firefox. So far so good. Now I'd like to debug a JavaScript file used by one of my pages. The first time I set a breakpoint in the file, IntelliJ asks me what the remote URL of the JavaScript file is. I provide it, but then get the following error in the IntelliJ debug console:

[doSetBreakpoint]: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [jsdIScript.isLineExecutable]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: chrome://jetbrains-connector/content/scripts.js :: anonymous :: line 132"  data: no] (chrome://jetbrains-connector/content/logging.js:2)

Am I doing something incorrectly?

Alex

10 comments

Which version of Firefox do you use? Does JavaScript debugger work for simple html file (create a html file with javascript code and select 'Debug' in
the popup menu)?

Having failed getting Firefox to connect to IntelliJ, I started the debugging session from IntelliJ which starts Firefox. So far so good. Now I'd like to debug a JavaScript file used by one of my pages. The first time I set a breakpoint in the file, IntelliJ asks me what the remote URL of the JavaScript file is. I provide it, but then get the following error in the IntelliJ debug console:

: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) "  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: chrome://jetbrains-connector/content/scripts.js :: anonymous :: line 132"  data: no] (chrome://jetbrains-connector/content/logging.js:2)

Am I doing something incorrectly?

Alex

---
Original message URL: http://www.jetbrains.net/devnet/message/5263210#5263210



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Nikolay,

With a plain HTML file (attached), I don't get that error, but breakpoints don't do anything. I.e., if in that example I click on the button, I see the alert without IntelliJ breaking on the line with the call to alert(). I am using Firefox 3.6.3 on OS X.

And of course, the issue with JavaScript files remains, as in practice, I don't want to debug inline JavaScript code, but code in separate JavaScript files loaded by the page.

Alex



Attachment(s):
gaga.html.zip
0

Nikolay,

I think I figure this one out: the debugger doesn't work at all if Firebug is enabled. It seems that Firebug needs to be disabled when Firefox is started by IntelliJ. Disabling Firebug after Firefox has started doesn't do the trick for me.

Do you recommend that I add a bug in YouTrack about this?

Alex
0

Alex,

IDEA Extension for Firefox and Firebug indeed have some collisions because they use the same API of Firefox. However I thought that I've fixed these
problems. Does the debugger work if you disable 'Script' panel of Firebug or you need to switch Firebug off completely? Anyway the issue in YouTrack
is welcome.

Nikolay,

I think I figure this one out: the debugger doesn't work at all if Firebug is enabled. It seems that Firebug needs to be disabled when Firefox is started by IntelliJ. Disabling Firebug after Firefox has started doesn't do the trick for me.
Do you recommend that I add a bug in YouTrack about this?
Alex
---
Original message URL: http://www.jetbrains.net/devnet/message/5263757#5263757



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Hi Nikolay,

If I just disable the Script tab, when I restart Firefox, it comes back enabled. Not sure if this is something that I'm doing wrong, but it seems that I really have to disable Firebug entirely not to have the Script tab enabled the next time Firefox is restarted. (This is with Firefox 3.6.3, Firebug 1.5.4.)

Alex

IDEA Extension for Firefox and Firebug indeed have some collisions because they use the same API of Firefox. However I thought that I've fixed these
problems. Does the debugger work if you disable 'Script' panel of Firebug or you need to switch Firebug off completely? Anyway the issue in YouTrack
is welcome.

0

Will it help if you right-click on Firebug icon at the bottom right corner of Firefox window and select 'Disable all panels' in the popup menu?

Hi Nikolay,

If I just disable the Script tab, when I restart Firefox, it comes back enabled. Not sure if this is something that I'm doing wrong, but it seems that I really have to disable Firebug entirely not to have the Script tab enabled the next time Firefox is restarted. (This is with Firefox 3.6.3, Firebug 1.5.4.)

Alex

IDEA Extension for Firefox and Firebug indeed have some collisions
> because they use the same API of Firefox. However I thought that I've
> fixed these
> problems. Does the debugger work if you disable
> 'Script' panel of Firebug or you need to switch Firebug off completely?
> Anyway the issue in YouTrack
> is welcome.


---
Original message URL: http://www.jetbrains.net/devnet/message/5263956#5263956



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Nikolay,

Yes, disabling all panels works. But this is equivalent to disabling Firebug :). I.e. I'd like to be able to disable just the Script panel, use IntelliJ for JavaScript debugging, and still use the rest of the Firebug functionality. Are you able to do this on your side?

Alex

0

Alex,

I think it's enough to disable 'Script' and 'Console' panels. 'Console' panel depends on 'Script', so if 'Console' is enabled Firebug will enable
'Script' panel as well. I'll try to disable both these panels from IDEA.

Nikolay,

Yes, disabling all panels works. But this is equivalent to disabling Firebug :). I.e. I'd like to be able to disable just the Script panel, use IntelliJ for JavaScript debugging, and still use the rest of the Firebug functionality. Are you able to do this on your side?

Alex

---
Original message URL: http://www.jetbrains.net/devnet/message/5264073#5264073



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Nikolay,

Yes, you're right! This is it: those of us using Firebug should, short of completely disabling Firebug, at least disable the Console and Script tabs. Thank you for this tip.

Alex

0

Please sign in to leave a comment.