Frequent "Project Files Changed" message ever since upgrading to 14

Answered

Hello,
Ever since I've upgraded to version 14, I get frequent intermittent popup messages that prevent me from using the IDE until I either dismiss the popup or reload my project. This has happened with both python and CFML projects. The message says:

"Project Files Changed

Project components were changed externally and cannot be reloaded:

RunManager

Would you like to reload project?"

Screenshot is attached.

Any info on how this can be remedied would be appreciated

thanks,
Tony



Attachment(s):
intellij_message.png
14 comments
Comment actions Permalink

I haven't heard of anyone having that issue, and I'm not seeing anything in the YouTrack bug report system. I'd recommend disabling all third party (i.e. non-bundled) plug-ins, restarting and see if the issue goes away. If so, you can determine which plug-in it is and contact the author. If not, I'd recommend opening a bug report. Also, has anything else on your system changed? Is it possible something else if touching those files causing the IntelliJ IDEA file monitor to thing they have been changed?

0
Comment actions Permalink

Actually, I've seen this meesage a few times recently, altough I have no idea what's the source of this behavior (I have no 3rd party plugins installed). All my projects/modules are either pure Java or Java/Maven.
Environment:

IntelliJ IDEA 14.0.2

Build #IU-139.659, built on December 6, 2014

JRE: 1.8.0_25-b18 amd64

JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation

Windows 8.1 x64

0
Comment actions Permalink

I have been having the same issue. I would love to know what the heck the solution is. I will be troubleshooting on my own, but if anyone stumbles on a resolution, I would love to know. If I find it first, I will post.


SimplyMarkB!



Attachment(s):
intellij.jpg
0
Comment actions Permalink

I seemed to have fixed the problem, but only by creating a new project. :-( Not an impressive fix, but it was fast and resolved the issue.

-SimplyMarkB

0
Comment actions Permalink

Thanks Mark. I tried creating a brand new project per your suggestion, but unfortunately I'm still seeing
the message come up. Have you still not seen it? Looks like I'll have to file a bug report.

0
Comment actions Permalink

Ok, I see now that a bug report has been submitted for this and it seems that the Time Tracking plugin is the culprit.

https://youtrack.jetbrains.com/issue/IDEA-132490

I've deactivated it so hopefully this will 'fix' it. Hope that plugin gets fixed!

0
Comment actions Permalink

Well re-creating the project and disabling the Time Tracking plugin ended up not helping. Still getting this annoying popup. It's enough to make me seriously consider dumping IDEA

0
Comment actions Permalink

Well, I haven't encountered this again since upgrading to 14.1 (it's been a couple of days and this used to happen to me multiple times daily). So hopefully this is fixed?

0
Comment actions Permalink

Thanks, Tony Garcia. I have updated the IntelliJ but I see the problem again. Can anyone help me out?

0
Comment actions Permalink

Could you please attach idea.log ("Help | Show Log in...") after restarting  IDEa and facing the issue again?

0
Comment actions Permalink

Hey Guys i resolved the issue by stopping the auto sync 

go to File>>Settings>>System Settings>> uncheck all the options for Synchronization

it should work 

0
Comment actions Permalink

I see this when running WebStorm and IDEA at the same time. If I kill one of them, the popups stop. Still pretty annoying since having both going is handy when you're working on both front and back ends.

0
Comment actions Permalink

Hi All, 

Did anyone find another way to correct this issue? Tried this and I am still getting this issue.

Popup is still coming up. It is actually forcing me to reload the project every time I try to stash something.

0
Comment actions Permalink

Please report at https://youtrack.jetbrains.com/issues/IDEA with the logs attached (https://intellij-support.jetbrains.com/hc/articles/207241085). It could be some plug-in issue or specific to your environment, file system, etc.

0

Please sign in to leave a comment.