Auto complete in intellij ide for java script

HI,

I use intellij version 14.0.3 and I want to use code complete for java-script which is not working ,
for example if I type element. and press ctrl+space I dont get any suggestion ...
any idea?

6 comments
Comment actions Permalink

Make sure JavaScript plug-in is enabled and .js files are associated with it.

Please try File | Invalidate Caches | Invalidate and Restart.

Contact support with idea.log (https://intellij-support.jetbrains.com/entries/23352446) and a sample project if the issue persists: https://intellij-support.jetbrains.com/home/ .

0
Comment actions Permalink

"Make sure JavaScript plug-in is enabled and .js files are associated with it."

the plugin is enable
How should I do the association ,please provide the steps...
In addtion this IDE is working too slow, when I type quick I have annoying delay...

Thanks!

0
Comment actions Permalink

Firstly, I do believe code completion is case sensitive. So typeing "element" with a lowercase 'e', will not bring up the suggestions drop-down. Typing "Element" with an upper-case 'E' will.

Second, Ensure you haven't disabled the keybinding for this option. I suggest going under your Preferences -> Appearance and Behavior -> Keymap, and then make a "test" preferences at the top by copying your current preferences to test new changes in, that way you don't need to backtrack if you accidently mess something up when you change multiple things.

Below is a picture of the capital 'E' situation of what happens when I do this. Along with the binding you'll be looking for to revert this to get the drop-down box.

I hope I'm right about this.

Let me know!



Attachment(s):
Screen Shot 2015-03-16 at 5.17.45 AM.png
Screen Shot 2015-03-16 at 5.15.21 AM.png
0
Comment actions Permalink

Thanks but this was not helped
Any other idea ?

Thanks in advance.

0
Comment actions Permalink

Contact support with the log, sample project and CPU snapshots.

0

Please sign in to leave a comment.