[bug] Keyboard get locked in IntelliJ IDEA

Answered

Hello,
I'm experiencing a problem with my keyboard with IDEA. While working with idea, keyboard get locked up for no reason. After that, I can't type anything IN idea.(works perfectly in other apps.) I have to restart Idea to fix the problem. Mouse works fine, kb problem is only inside idea. This happens frequently, so it is a pain for me. I switched to idea 9.0.2 from 9.0.1 thinking it may had solved the problem. But apparently not.

Please give me a solution for this.
Im using Ubuntu 10.04 Ubuntu Lucid.

Thanks,
/kasun

23 comments
Comment actions Permalink

Hi Kasun,

Unfortunately, such kind of reporting doesn't help us to investigate/reproduce the problem. Please provide more details about that. You can start from submitting IDEA thread dump when the application is in problem state.

Regards, Denis

0
Comment actions Permalink

Yes. sorry. I thought you people may have identified it already and there may  be a possible solution now.
When the problem occurs there  is no errors/exceptions in the terminal.

Here is the thread dump: http://pastebin.com/Uxu9sNtt

Thanks,
/kasun

0
Comment actions Permalink

Thanks, we'll check


0
Comment actions Permalink

Same problem here. Also Ubuntu 10.04. Java version 1.6.0_20-b02.

0
Comment actions Permalink

It's a little relief to see other people too have this problem. I thought it was some problem with my machine!
As you too using Ubuntu 10.04, this bug probably attributed to Ubuntu 10.04! Idea worked perfectly with Ubuntu 9.10.

Regards,
/Kasun

0
Comment actions Permalink

Unfortunately, it also happened for me with 9.10. I upgraded to 10.4 in the hope that it would fix it.

Strangely, I also use IntelliJ on my work computer, which is running 9.10, and it works fine.

0
Comment actions Permalink

same problem here, using win7x64. happened twice in one month or so. i'll see if i can provide more information once it happens again

0
Comment actions Permalink

Hello folks,
I think I got my problem fixed. For me, the error was with the IBUS package that comes under Ubuntu. It seems IBUS is buggy, causing keyboard errors for Java programs. This issue is not related to IDEA but for all Java programs under Ubuntu/Linux. I faced to the same issue with JProfiler.

So, the solution when keyboard got stuck is to restart the IBUS, by clicking the keyboard icon in upper-right corner -> restart. This temporarily fixes the issue. If you don't want IBUS (you don't use languages other than English, ) remove it. I suspect this occurs when we switch through different keyboard layouts, but I'm not entirely sure.

That's it. Sorry for bothering you Denis. And thanks for taking time to look at this. You all have made a really nice product.

Regards,
Kasun Gajasinghe

1
Comment actions Permalink

Same problem here with Intellij 10.0 Community Edition, Linux Arch 64bit, JDK 1.6.0_18

the letters keys of the keyboard are not answering, but strangely the backspace, return and the arrows keys are working fine...

I can easily reproduce the problem by formating Java code with Jalopy (version 1.9). This action of formatting the code with Jalopy produces an exception visible in "IDE Fatal Error" panel:


Error during dispatching of java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=com.triemax.g3@3ecd0da4,notifier=null,catchExceptions=false,when=1292428996175] on sun.awt.X11.XToolkit@1afd2e1f: Setting of glass pane for IdeFrame is prohibited
java.lang.IllegalStateException: Setting of glass pane for IdeFrame is prohibited
at com.intellij.openapi.wm.impl.IdeRootPane.setGlassPane(IdeRootPane.java:131)
at com.triemax.e3.a(e3.java:45)
at com.triemax.e3.a(e3.java:21)
at com.triemax.g3.run(g3.java:2)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at com.intellij.ide.IdeEventQueue.defaultDispatchEvent(IdeEventQueue.java:652)
at com.intellij.ide.IdeEventQueue._dispatchEvent(IdeEventQueue.java:506)
at com.intellij.ide.IdeEventQueue._dispatchEvent(IdeEventQueue.java:405)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:369)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)



After that the keyboard is not working any more....

I never got this problem with the version 9.X, that is a pity because the new version 10 is very fast and pleasant....I might uninstall it to go back with 9.X....



Thanks
Nicolas






0
Comment actions Permalink

Just to confirm -- this is still happening.

ibus can be restarted on the cli with `ibus-daemon -r`

ibus-daemon 1.5.5
Ubuntu 14.4 here

0
Comment actions Permalink

PyCharm professional 2016.2.1 on Linux

ibus-daemon 1.5.5
Ubuntu 14.4

This is still an issue. Any work-arounds?

0
Comment actions Permalink

my workaround is hacking idea.sh and add these two lines

XMODIFIERS=idea.sh #add this line
export XMODIFIERS #add this line too

before this comment:

# ---------------------------------------------------------------------
# Run the IDE.
# ---------------------------------------------------------------------

i do not know if that has any side effects. i never noticed any

0
Comment actions Permalink

Same issue still happening. Besides, I'm using MacOSX Sierra and my JDK Version : 1.8

2
Comment actions Permalink

Same issue here, on macOSX Sierra, both on IntelliJ and CLion.

It looks like the VIM plugin is causing this, after the keyboard gets stuck disabling `Vim emulator` won't help.

0
Comment actions Permalink

Got the same problem here.

ibus-daemon version 1.5.5
Ubuntu 14.04.5
Pycharm 2016.2.2

I debbuged myself with the "ibus-daemon -r" command

I worked a lot on webstorm, I didn't get this.

0
Comment actions Permalink

I have faced this issue twice this week. (no vim plugin installed)

IntelliJ IDEA 2018.1.5 (Ultimate Edition)
Build #IU-181.5281.24, built on June 12, 2018
JRE: 1.8.0_152-release-1136-b39 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.5

Any solution for this?

0
Comment actions Permalink

@Yamenj this thread is about Linux iBus issue, see https://youtrack.jetbrains.com/issue/IDEA-78860.

It looks like you have different issue. It might be better to start another thread. Please describe what happens exactly.

0
Comment actions Permalink

I'd like to report this issue appears on my ubuntu 18.04.2 LTS in intellij 2019.1.

As an additional info: when the keyboard is locked, shift, ctrl and alt are working.

So for example I can shift+click to select a portion of text, or ctrl+shift+click to have a multi edit mode.

Also alt+tab gets me out of intellij.

1
Comment actions Permalink

Does it happen with ibus disabled? It could be a completely different problem, so a proper report at https://youtrack.jetbrains.com/issues/IDEA with the logs attached would be a better option.

0
Comment actions Permalink

Also appears on a Pop!_OS 20.04 LTS Linux (basically Ubuntu) with Gnome 3.36.2 and X11.
Restarting Ibus on the shell with  `ibus-daemon -r` helped.

For whatever reasons appears now, maybe after an update to 20.04 or I didn't recognize it earlier.
Also as described above: Only affects IntelliJ - the keyboard is usable outside of IntelliJ.
The mouse still works.

Maybe it's just my imagination, but I think it happens when I open a file within a JAR which is not editable.
Then after returning to other files, which are editable, the keyboard freezes.
It's not deterministic though, so I am not sure if this is just randomly happening or related to this action.

2
Comment actions Permalink

Please check the https://youtrack.jetbrains.com/issue/IDEA-206614 E.g. see JBR-1573 and the 

-Drecreate.x11.input.method=true 

workaround. Check also other linked issues.

0
Comment actions Permalink

I think there are a lot of other issues that are related... with ibus-daemon being the cause... I just was so annoyed... looking at many Intellij issues about a keyboard that was locked up... and I'm dealing with this for days... restarting 5x per day.... all fixed instantly with a pkill -f ibus-daemon.  I don't care about a silly ibus input ... I care a lot about Intellij working reliably.

0

Please sign in to leave a comment.