Why Doesn't Directory Show Up In Project Tree

I have a module "JUnit" that contains a directory testFiles/ACS and under ACS there are 11 sub directories, but only 3 of them show up in the project tree.

At first I thought that it might have something to do with spaces in the directory names but I refactored one of the directories to remove the spaces and it still doesn't show up under its new name "ACS.HRC.Suite".

So am I doing something wrong, or is IDEA?

Thank you,

Donald

9 comments

Hello Donald,

DM> I have a module "JUnit" that contains a directory testFiles/ACS and
DM> under ACS there are 11 sub directories, but only 3 of them show up
DM> in the project tree.
DM>
DM> At first I thought that it might have something to do with spaces in
DM> the directory names but I refactored one of the directories to
DM> remove the spaces and it still doesn't show up under its new name
DM> "ACS.HRC.Suite".
DM>
DM> So am I doing something wrong, or is IDEA?

Are any of these directories added to a project as libraries? Do any of them
match masks specified in Settings | General | Exclude files and folders?

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Dmitry,

They are not added as libraries. They are part of a directory tree whose root is marked as regular source. They do not match any of the masks listed in Settings | General | Ignore files and folders.

I did list the full path (albeit in a roundabout manner). Just to be clear, it is:

JUNIT/testFiles/ACS/ACS.HRC.Suite

Thank you,

Donald

0

Can you reproduce this problem in the isolated project? Does it help if you reset IDEA caches by deleting ~\.IntelliJIdea60\system directory?

If the problem remains, please attach a sample project illustrating it and idea.log file from ~\.IntelliJIdea60\system\log.

0

I attempted to simulate the problem in a bare-bones test project with no luck.

It appears that things are organized a little differently on the Mac. I'm guessing that it would be something from ~/Library/caches/IntelliJIDEA60/ that I would want to delete, but I'm hesitant about deleting all of it without even being sure that's the correct directory.

Thank you,

Donald

0

Try deleting /Users/[user_name]/Library/Caches/IntelliJIDEA60/caches first.

Message was edited by:
Serge Baranov

0

It spent a good long while rebuilding the caches, but that didn't help.

Donald

0

Then try to set up your project from scratch.

0

Are you looking at the package view (my guess would be that such names are
illegal package elements)?


0

Not the prettiest answer, but it worked.

I had been wanting to rebuild the project directory from scratch anyway - I just didn't feel like doing it yet. :)

Thank you,

Donald

0

Please sign in to leave a comment.