Running Android unit tests with Java SE

I've set up a project with two modules, one is an Android module containing my Android codebase. The other is a regular Java module that contains unit test code that excercises some of the classes in the Android module. In the module config the test module is dependent on the Android one.

In IntelliJ 10.0 this setup worked like a charm. I could execute the unit tests in the Java module and run them using the regular Java SE runtime and JUnit runner.
Since upgrading to 10.5 this no longer seems to work. When compiling the test module I get compiler errors stating that the classes from the Android module cannot be found.

Should this setup work in the first place? In other words, should I consider this a regression. Or was the fact that it worked in 10.0 just by chance?

2 comments
Comment actions Permalink

It looks like a bug to me. Classes from the dependent Android module should be available to its parent module.
Please file an issue with a small sample project attached to reproduce this problem:
http://youtrack.jetbrains.net/issues/IDEA.

0

Please sign in to leave a comment.