Intellij 10 fails to start after latest Java preview update on OS X

Hi

After installing the latest Java preview my Intellij 10 has stopped working  – it fails to start. (both Netbeans and Eclipse starts fine, so it must be a Intellij launcher peculiarity) The log shows:
2010/12/20 11:15:59 AM [0x0-0x4a04a].com.jetbrains.intellij[932] error in posix_spawn: 2
2010/12/20 11:15:59 AM [0x0-0x4a04a].com.jetbrains.intellij[932] [JavaAppLauncher Error] Failed to re-execute into [i386] from [x86_64]
2010/12/20 11:15:59 AM [0x0-0x4a04a].com.jetbrains.intellij[932] [JavaAppLauncher Error] unable to find a version of Java to launch
2010/12/20 11:15:59 AM com.apple.launchd.peruser.501[376] ([0x0-0x4a04a].com.jetbrains.intellij[932]) Exited with exit code: 1
I have reported this to Apple - Bug ID# 8788298
I know we are not suppose to discuss previews but unfortunately I am stumped by this problem and I need to continue with production work.
Any ideas?

Regards
Ian
2 comments
Comment actions Permalink

Try to replace /Applications/IntelliJ IDEA 10.app/Contents/MacOS/idea binary with /System/Library/Frameworks/JavaVM.framework/Resources/MacOS/JavaApplicationStub.

0
Comment actions Permalink

Thanks Serge - It seems I had bigger problems and I ended up reinstalling OS X along with the Java updates. I must have messed up somehwere. :(
All seems to be OK now, although I had to trash my Intellij Preferences before I got it working - for some reason Intellij just hanged doing thread dumps.
Regards
Ian

0

Please sign in to leave a comment.