The problem with IntelliJ's taskbar button in Gnome

If you have multiple IntelliJ's open in Gnome, their taskbar buttons often disappear. This makes it hard to know in which IntelliJ you're currently busy (especially when working on multiple versions of the same project) and makes it hard to switch to different IntelliJ windows.

Is there anyone who uses IntelliJ in Gnome and has also seen this behaviour?

I've posted about this before once, but the post was ignored. Still, this is a really big problem for me. What is the cause, Gnome, Java or IntelliJ?

Is there any trick at all to get this working properly? This would be extremely helpful.

So what happens is: normally a program window has a taskbar button. If two intellij's are open, there should be two taskbar buttons. If in any of the intellij's, any sub-dialog is shown, then the intellij taskbar button of that window disappears forever, and the only way to go to its window is minimizing all others in front of it.


I know someone who uses some fancy vertical sidebars in his Gnome, and those sidebars show a button for IntelliJ at all times, but I myself am very conservative when it comes to how a desktop looks and need a classic horizontal taskbar at the bottom with classic window buttons in it that has the icon and name of the window. And normally this taskbar works properly, except for IntelliJ for whatever strange reason.

2 comments
Comment actions Permalink

Ok, hopefully this year old Gnome bug report and two year old IntelliJ bug report will get resolved some day....

Since that means I'll be stuck with this taskbar button problem for at least a year + the time between ubuntu releases, does anyone know tricks to make the life of us intellij taskbar bug sufferers easier?

For example I know that if the IntelliJ buttons are gone, that pressing the "Show Desktop" button of gnome twice in a row, brings all buttons in the taskbar back!

Or apparantly KDE doesn't have the problem, but I don't like KDE anymore since version 4

Anyone else has tips or tricks about this here? Some Gnome setting maybe? It'd be highly appreciated.

0

Please sign in to leave a comment.