PhpStorm starts in a gibberish language for the UI

PhpStorm.jpg

I installed PhpStorm for the first time on windows and started it up to this screen. The UI is not in English and appears this way. I wanted to look for an option to change it to English, but the options menu is also illegible. Is there a langauge setting that I can change or, Am i missing a font used by the IDE ?

I opened a support ticket, but I am yet to recieve a reply (probably due to the holidays).
Any help is greatly apprecieated.

5 comments
Comment actions Permalink

Hi there,

It must be a font issue as IDE itself has English as only interface language.

You may try assigning different font at "Settings/Preferences | Appearance & Behaviour | Appearance --> Override default fonts"

screen01.png

You may also try different GUI Theme (same settings page), especially if you have HiDPI screen (try other than Windows)

0
Comment actions Permalink

Thanks a lot. Overriding the default fonts and setting it to another font and clickign Ok solved the issue. I noticed that the issue is only when Segoi UI is selected (Even with Overriding option).

0
Comment actions Permalink

I have this problem with WebStorm, and have looked at the site and saw this as the recommendation. But I have to say with the entire menuing system gibberish it makes it a little hard to navigate to properties and change fonts???? All of this must be stored somewhere in a .XML or .INI or registry so we can accomplish this task without trying to use the program! 

0
Comment actions Permalink

@Michael Gamble

Cannot speak for original issue (almost 3 years ago) .. .but these days it seems to happen because of Material UI Theme plugin.

https://intellij-support.jetbrains.com/hc/en-us/community/posts/360000919359-IDE-interface-encoding-problem-

>All of this must be stored somewhere in a .XML or .INI or registry so we can accomplish this task without trying to use the program! 

If you have changed it (font) in the past -- yes. If not (default font) then you may have that config var empty / not present at all.

0
Comment actions Permalink

I found somwhere to reinstall the ROBO font, that seemed to do the trick. 

0

Please sign in to leave a comment.