using Assertions in IDEA 5.1

I'm trying assertions in IDEA5.1 with target level set either 1.4 or 1.5 and I have tried the following setting in VM: -ea and -source 1.4 in Program Parameters, but still unable to compile and run the porgram.

Please help!

1 comment

You don't need to specify -source 1.4. Instead you need to configure Language Level for project (see Settings | Modules). Set it to 1.4 or 1.5.

If this doesn't help, remove JDK configuration and add it from scratch,

-ea option should be added to the Run/Debug configuration VM Options to use assertions at run-time.

0

Please sign in to leave a comment.