leave trailing space on empty javadoc line

I'm using IDEA on a big project where most developers are using Eclipse. Eclipse puts a space after the * on empty Javadoc lines. IDEA is deleting all those spaces, even though I am not reformatting the file, and even though I've disabled Javadoc formatting on the code style configuration! This could cause me unnecessary conflicts with the other developers. Is there a way I can get IDEA to leave those spaces alone?

Cheers,
11011011

3 comments
Comment actions Permalink

By the way, this is on 5.1.1 (build 4192). I'll try it on 5.1.2 on Monday.

0
Comment actions Permalink

Click Settings->Editor->Behavior and make sure that "Strip trailing spaces on Save" is set to "None".

0
Comment actions Permalink

Thanks! That worked. It was set to Modified Lines, but IDEA seems to incorrectly consider those empty javadoc lines as modified. I'll post a JIRA issue if 5.1.2 has the same problem.

Cheers,
11011011

0

Please sign in to leave a comment.