configure two different version running on same machine

Hi I've just downloaded latest EAP and installed it in /jetbrains/phpstormeap folder. I also have phpstorm installed in /jetbrains/phpstorm.

idea.properties in phpstorm folder as follows

SET IDEA_PROPERTIES="C:/Program Files/JetBrains/PhpStorm/bin"

idea.config.path="C:/Program Files/JetBrains/webide/config"
idea.system.path="C:/Program Files/JetBrains/webide/system"
idea.plugins.path="C:/Program Files/JetBrains/webide/config/plugins"
idea.log.path="C:/Program Files/JetBrains/webide/system/log"

idea.properties for phpstormeap is as follows


SET IDEA_PROPERTIES="C:/Program Files/JetBrains/PhpStormeap/bin"
idea.config.path="C:/Program Files/JetBrains/webideeap/config"
idea.system.path="C:/Program Files/JetBrains/webideeap/system"
idea.plugins.path="C:/Program Files/JetBrains/webideeap/config/plugins"
idea.log.path="C:/Program Files/JetBrains/webideeap/system/log"



Now when i open phpstormeap it automatically open project on which i am working in phpstorm. from where it is picking project info?can't they be run at same time without interferreing with each other?

4 comments
Comment actions Permalink

I run multiple versions all the time. I would be sure EAP is using the intended config file.
New EAP uses; SET WEBIDE_PROPERTIES= unlike 3.0.x, which uses; SET IDEA_PROPERTIES= but you don't even need to set it if you leave the idea.properties file in it's default location.
Also be sure you are saving the properties file with admin rights.
Anyway...

0
Comment actions Permalink

Just edit the properties files, you don't need to mess with the environment: http://devnet.jetbrains.net/docs/DOC-181.


0
Comment actions Permalink

Hi

I edited properties file but now when i start phpstorm eap it created .WebIde folder in c:\documents and settings\username\ and read config from there. I have created webide folder in bin folder at /jetbrains/phpstorm/bin but it is not parsing those settings. how i can fix this issue. ?

Thanks

0
Comment actions Permalink

Did you remove comments (#) before the setting lines?

Should be:
idea.config.path=${user.home}/.WebIde/config

Changins the path has effect after restart.


0

Please sign in to leave a comment.