Disable refreshing VCS history

Answered

Hi

I use subversion as a VCS. Whenever I update a project or file, phpstorm starts to refresh the VCS history. This generally takes at least 10-20 minutes to complete and puts CPU usage at 100% on one core, which makes the UI incredibly slow for anything else.

Can I disable this refreshing process? Or limit how often it occurs? It really seems so unnecessary and it's limiting my ability to be productive.

Thanks

3 comments
Comment actions Permalink

Do you keep the files on the fast local drive? Can you provide a CPU snapshot for this problem? See http://devnet.jetbrains.net/docs/DOC-192.

0
Comment actions Permalink

I have large number of projects and slow VPN connection, and honestly I see totally no reason why I would need to refresh SVN history. Why cannot this be disabled?

0
Comment actions Permalink

Harley Mellifont The IDE is refreshing the local status of the files to correctly show them in the Local changes and other respective places therefore this process cannot be disabled. 
Overall it is a known issue, please vote:
https://youtrack.jetbrains.com/issue/IDEA-119539

Maciej Miklas could you please submit a support ticket and attach log files to it?

0

Please sign in to leave a comment.