Working set size goes down on minimizing IDE window on windows

This may not be something worth mentioning or not but I made a discovery today about reclaiming some memory from PhpStorm when it starts getting up there, especially when you need some memory for something else at the moment.   I do not know if this works in previous versions to 2.0.1 or not, I never tried it until now.

I had open my task manager, I am using Windows XP Pro SP 3, and noticed the memory usage of PhpStorm was close to 300MB, which I guess is "normal" range and on a whim I just minimized the application and the memory usage dropped from close to 300MB to close to 10MB.  I was shocked, did I break it, is there a bug, was there a "fix" with the new version?    The memory doesn't stay that low it climbs dramatically once you being to use PhpStorm again but it doesn't immediately go back to the high level.    I checked and when I minimize the application the memory that is released does go back to the system, at least on my computer.

Is not a "fix" or anything but someone else may find this useful if they never checked this out.

I have NO idea what happens when you minimize the application, if things are reset or caches are cleared or anything I don't know.

I just thought this was more than interesting.  I did not turn off PhpStorm or mess with any settings or do anything other than minimize it to the taskbar, that was it.


Thanks.

4 comments
Comment actions Permalink

You can also click on the little memory meter in the bottom right and it will free up some memory.

0
Comment actions Permalink

Hmm, doesn't work for me. Always 300+ MB.

0
Comment actions Permalink

This is "feature" of JVM on Windows. And actually this is quite bad and hurts java app performance a lot.
The reason is that app is basically just fully swapped out on minimize.

FYI: Netbeans and other big java apps also suffering, see http://www.java-gaming.org/index.php?topic=11865.0

0
Comment actions Permalink

This will only make the app slower until caches are populated again.

0

Please sign in to leave a comment.