DB Navigator connection

Hello,

i tried to configure a mysql connection via DB Navigator, but it doesn´t work. At the online help is only a screen from settings with ORA DB. Is there any documentation for a mysql connection setting?

best regards

Sascha

6 comments
Comment actions Permalink

DB Navigator is a 2rd party plugin and we can't provide any support or information on it.

Anyway, may be you just want to use built-in database support?.. Its proven to work great with all supported databases (incluging mysql).
Go to Tools|Data Sources to add a connection. Also, visit Settings|SQL dialects and set project dialect accordingly, to enable completion and proper SQL systax checking.

0
Comment actions Permalink

Hi Sascha,

Have a look at the actual DB Navigator plugin page: http://plugins.jetbrains.com/plugin/?webide&id=1800, especially at comment dated 2011-02-04 -- this may be what you need (copied here for convenience):

Follow this steps to active a MySQL connection (I used this for my local MAMP setup)

1) Install DB navigator plugin: Settings >> plugins >> "available" tab
2) Download MySQL jdbc connector >> http://www.mysql.com/downloads/connector/j/
3) Unpack MySQL jdbc connector to a directory (ex: /home/documents/mysql_connector)
4) Add a DB connection: Settings >> DB Connection

Example for MySQL
Name: personal connection name (ex: MAMP MySQL)
Description: some more information (ex: local mamp mysql server)
Driver Library: location of the MySQL jdbc connector (/home/documents/mysql_connector/mysql-connector-xxxx-bin.jar)
Driver: the perfered driver
URL: the connection URL with jdbc reference (ex: "jdbc:mysql://localhost:8889/")

user: the password for the mysql connection (ex MAMP: root)
password: the password for the mysql connection (ex MAMP: root)

In any case -- I think the setup (parameters) should be similar to PhpStorm's built-it functionality -- see the image attached to this post.

0
Comment actions Permalink

Hello Andriy,

thx alot for this information. Now it works fine:)

regards

Sascha

0
Comment actions Permalink

Hello,

now i have another problem. After installing the driver libary, i became a error message when i will save my settings.

Have a look here:
settings_error.jpg


best regards

Sascha

0
Comment actions Permalink

No idea, but if it caused by DB Navigator plugin then you should be contacting its' author.

P.S.
Maybe, just maybe, it is caused by some symbols (apostrophe) in the file path ?

0
Comment actions Permalink

Hello,

ok i need more coffee this morning. I have manually changed a path and forget it.

Sorry for that.

Another once, thx

best wishes

Sascha

0

Please sign in to leave a comment.