6 comments
Comment actions Permalink

Hi Quadro Val,

PhpStorm definitely has something similar implemented: not exactly "match closing tag" -- rather highlighting the same variable/tag. I can clearly see matches on your 2nd screenshot (PhpStorm one). The problem is -- the colour of matched tag is very similar to the HTML tag background. Change the background colour in File | Settings | Editor | Colors & Fonts | General | Search result to something different (like green background) and see the results.

On another hand -- PhpStorm can highlight matching opening/closing bracket/brace (it's just you have to place cursor before opening < or after closing > symbols -- see  File | Settings | Editor | Colors & Fonts | General | Matched brace).

You can also use Ctrl+[ and Ctrl+] to jump between opening and closing tags (officially it's called "Move caret to code block start/end").

0
Comment actions Permalink

Hi Andriy.
Thanks for reply.
>>I can clearly see matches on your 2nd screenshot
Unfortunately you can see all matches of this kind of tag but not the spcific one. Let me show you
http://my.jetscreenshot.com/2591/20101102-wpgi-47kb

Closing tag is not defined properly sometimes
http://my.jetscreenshot.com/2591/20101102-bbhi-43kb

>>File | Settings | Editor | Colors & Fonts | General | Search result
this didn't take any affect for me in html
http://my.jetscreenshot.com/2591/20101102-ivz4-78kb

>>File | Settings | Editor | Colors & Fonts | General | Matched brace
I haven't found this setting , I use this version http://my.jetscreenshot.com/2591/20101102-fl8p-27kb

0
Comment actions Permalink

Hi Quadro Val,

>> I can clearly see matches on your 2nd screenshot
Unfortunately you can see all matches of this kind of tag but not the spcific one.
http://my.jetscreenshot.com/2591/20101102-wpgi-47kb

Yes, that is correct -- that's what I originally said: "highlighting the same variable/tag". I should have explained myself better (sorry about that -- it was like 2AM here).

If you think that this still does not satisfy your needs then please have a look at these tickets:
http://youtrack.jetbrains.net/issue/WI-1151?projectKey=WI
http://youtrack.jetbrains.net/issue/WI-1152?projectKey=WI
http://youtrack.jetbrains.net/issue/WI-3387?projectKey=WI
.. or create your own feature request:
http://youtrack.jetbrains.net/issues/WI#newissue=yes

Closing tag is not defined properly sometimes
http://my.jetscreenshot.com/2591/20101102-bbhi-43kb

Works fine for me all the time. But I'm using EAP build (v2 beta) -- it must be improved since v1.

You can try it yourself, but keep in mind -- it's a beta and sometimes builds having some performance/stability issues. Just backup your ".WebIde10" folder (located in your user home) -- the settings/file formats are not guaranteed to be backward compatible.
http://www.jetbrains.net/confluence/display/wi

>>File | Settings | Editor | Colors & Fonts | General | Search result
this didn't take any affect for me in html
http://my.jetscreenshot.com/2591/20101102-ivz4-78kb

Yep -- my mistake. Just checked again -- correct style is "Identifier under caret".

>>File | Settings | Editor | Colors & Fonts | General | Matched brace
I haven't found this setting , I use this version http://my.jetscreenshot.com/2591/20101102-fl8p-27kb

That's possible as I'm using v2 beta. But I think it should be there -- just scroll down a bit (to double check) -- in v2 it's right after Followed hyperlink style.

0
Comment actions Permalink

Tanks Andriy!
That tickets will solve my issue when they would be implemented, but I guess it will not be soon =)

0
Comment actions Permalink

Setting the style for Matched Braces seems to be a bit flakey.
I swore I set it just yesterday.
But now I cannot find it even in the location you specify.
In the selection list, "Followed hyperlink" is followed by "TODO defaults".
I hope it is my memory and not a bug.

0
Comment actions Permalink

Just checked in latest EAP build (PS-103.8) @ Settings | Editor | Colors & Fonts | General:
...
Hyperlink
Followed hyperlink
Matched brace
Unmatched brace
TODO defaults
...

Unfortunately I cannot say why you are unable to see these entries. Maybe (just maybe) your profile/settings got corrupted...

0

Please sign in to leave a comment.