PHP Code Completion, New Files, Copy-Paste

So I've just downloaded 95.136 and I love it... Save for some issues that are keeping me from being more productive with it than my existing IDE. Here are my issues.

PHP Code Completion

I'm not seeing all of the PHP code completion as advertised on the site and in the help files. I have the PHP plugin enabled, but code completion doesn't seem to work for things such as variable names and built-in PHP functions. Or, for example, when I start a brand-new file in a project and I define "class Something extends " it is apparently supposed to pop up a list of classes to extend, but mine isn't.

New Files

Currently to create a new file they have to be associated with a project. It would be nice if I could just create a new file outside of a project not named anything in particular, much like using KATE on KDE can. The editor could then contextually know I'm working with a PHP/HTML/XML/etc. file based on the syntax. PHP is easy, though, because the <?php tag is unique to the language.

Copy-Paste

I believe this to be an issue with PhpStorm because none of my other applications have this issue. I have my machine connected to another using Synergy and copy-pastes from all applications work correctly except from PhpStorm. At least, if I do a CTRL-A to select all then CTRL-C, the paste doesn't transmit across. But if I copy-paste a specific selection of text, it works.

I didn't put any of these into trackers because I wasn't sure if there were existing trackers, if I was off my rocker or some other reason. Running Gentoo Linux & JVM 1.6.0

11 comments

Do you invoke code completion with Ctrl+Space? Just tried create new file in my EAP 95.150:
new-file-extends.png

0

Ah, that did the trick. I guess I was expecting it to pop up on its own, since some of the other features do that (variable autocompletion has at times).

Well, that's 3/4 of one down, anyway... The only way I can get PhpStorm to show me the parameter list for functions as I'm typing them is to use CTRL-Space to finish the function name in the first place. On functions that are already entered and I'm just adding the parameters, I can't get the list of parameters using CTRL-Space, it tries to load the list of variables instead.

0

View|Parameter info has separate shortcut.

You may find reading Help|Tip of the day and Productivity guide useful.

Also there's quite powerful  Search|Find Action feature.

0

As for creating/opening files - we do not plan to change current methods of file name/type association in any not so distant future.

0

For other specific problems, such as Copy/Paste through Synergy please create bug reports directly in the project issue tracker  http://youtrack.jetbrains.net/issues/WI

0

I usually use eclipse, then tried out netbeans.  While trying out netbeans I hit the same synergy error of not the clipboard not being available to paste anything into the editor with ctrl+v

I managed to get it working by purging the synergy and quicksynergy that kubuntu 10.04 installed for me and instead installing the synergy plus from google.
http://code.google.com/p/synergy-plus/

same thing, just a forked version which worked. Instead of running synergy through quicksynergy i copied the old .synergy.conf from my ~/.quicksynergy/.synergy.conf to ~/
then in the terminal of the server
$ synergys

and on the client machine
$ synergyc -f 192.168.0.2

where the ip is the ip of the server.  This worked to fix synergy copy and paste with netbeans and i havent noticed any issues now that i have moved over to using PhpStorm.

Never noticed any problems while using eclipse.  netbeans has tagged it as a not going to fix/ not our issue.

oh, one thing i did notice though is that if you click ctrl+v to paste it didnt work, but if you click the middle mouse button paste would paste.

0

Looks like its Java/Swing on Linux bug (eclipse isn't affected as it uses its own native UI toolkit) and we're unable to fix it.

0

Switching to synergy-plus didn't fix that particular issue for me. :-/

0

Has anybody else been asking for things like this? Personally, the only reason I like having such a feature is because there are a lot of times I need to copy-paste out of my IDE to somewhere else. I like to use the IDE because it obviously gives me all of the tools I'll need, such as code coloring, autocompletion, etc. But the code I'm writing needs to be put somewhere else that the IDE has no access. :-/

0

Actually scratch that... It's working correctly now.

0

Please sign in to leave a comment.