undo / redo

Answered

Hallo,

Just noticed that the undo / redo function seems unusual :-)
I am used too the ctrl-z being undo, but there is usually the equivalent ctrl-y for redo

I havent yet worked out what ctrl-y does but it is definately not redo
Is there a redo function anywhere and when so what keyboard shortcut is it mapped to ?
Oh and what exactly does ctrl-y do (appart from messing up my code) :-)

thanks

11 comments
Comment actions Permalink

I was also extremely annoyed by this strange behaviour. But luckely, it seems that some smart developer at JetBrains was expecting this

Click File --> Settings --> Keymap
In that screen there is an option labeled Keymaps. Set this to Eclipse and hit OK.

Now you can use Ctrl+Z and Ctrl+Y, and a lot of other standard keys.

2
Comment actions Permalink

Shortcuts are displayed in all menus and action lists. Redo is under Edit main menu and is set to Ctrl-Shift-Z in default keymap. Ctlr-Y is mapped to Delete Current Line.

0
Comment actions Permalink

ahhh thanks

and now just out of curiosity what did ctrl-y do ?

0
Comment actions Permalink

The intent behind of having Eclipse keymap is only to help evaluators with Eclipse background to taste at least some basic features.
The problem is that IntellJ Platfrom philosophy and design and thus architecture and features are quite different from eclipse's (despite the fact that many eclipse's features are direct clone of ours). In most cases our features can't be mapped to eclipse's terminology. And if one decided to use IntelliJ platform based product and trying to make it look or behave like eclipse instead of adopting – he/she is simply wasting time.

0
Comment actions Permalink

i've discovered the remap keyboard shortcuts -so saved my own scheme abd can fiddle about there with my own settings !

thanks

0
Comment actions Permalink

Nice m8 i was so annoyed by this now i can wrk propperly.

0
Comment actions Permalink

ctlr+y delete line

 

0
Comment actions Permalink

so I have undone 15 actions, and wanted to redo all that, so I held ctrl+Y for quite a bit deleting over 10 lines. how do i recover to normal? thanks

0
Comment actions Permalink

Ramiz, could you please describe step-by-step the whole scenario?

Did I get it correctly?

- You made some actions (f.e., typed some code);

- Then you have undone these with Ctrl+Z;

- You deleted some lines with Ctrl+Y.

And your current goal is to return to the state from the first step (to the same code you have typed)?

0
Comment actions Permalink

Use CTRL SHIFT Z

0
Comment actions Permalink

I had to recover from git and start over, so it worked fine. but yeah that was initially the problem. I'm good now

0

Please sign in to leave a comment.