JSF Highlight

Answered

Hi,

I use JSF and Primefaces for development. When using JSF specific tags the code is not highlighted. I've attached a picture. When I disable JSF plugin, it is properly highlighted but without JSF support. My version of Intellij IDEA is 15.0.3. Also, I use a custom color scheme, this one - http://color-themes.com/?view=theme&id=563a1a7680b4acf11273ae92

How to make it work as intended?

 

Thank you,

Chris

 

7 comments
Comment actions Permalink

Did you try it with all the default settings and color scheme? Maybe the theme that you are using doesn't specify the colors for these elements.

1
Comment actions Permalink

Thanks for answering Serge. Actually yes, when it's Darcula color scheme (which is bundled), the highlight is fine. With any other non-bundled color scheme the JSF part is not highlighted. When I disable JSF Plugin, highlight is fine, but there's no other JSF features I need.

0
Comment actions Permalink

You may contact the maintainers of these color schemes so that they update them to work with the current version.

0
Comment actions Permalink

That's an option, thanks. I'll try to reach the maintainer. As I understand some changes between versions have been made, because I remember with older versions there were no problems.

0
Comment actions Permalink

Same problem here. I wonder, if the settings from the maintainers are wrong, it should be possible to adjust the settings in the dialog Settings->Editor->Colors&Fonts. But this is not possible. What kind is to choose? XML? Or is the type xhtml/jsf missing here? Also in my case all the tags using namespace-prefix cannot be adjusted. But colorscheme of tags without namespace can be adjusted using XML-entry/kind.

And sometimes the code-display is mixed! So it seems to me, there could be a bug in IDEA.

0
Comment actions Permalink

This one worked for me: go to Editor > Color Scheme > Language Defaults > Template language and uncheck Foreground checkbox

2
Comment actions Permalink

@Nik Shikov Thanks. Your sollution works for me.

0

Please sign in to leave a comment.