Disabling App Nap on Mac

Answered

Hi,

 

My applications under MacOS are running sluggish because of the App Nap feature. It looks like IntelliJ does not support disabling this feature.

 

Is there a way/hack to disable this feature only for IntelliJ?

 

Thank you.

5 comments
Comment actions Permalink
Official comment

Thanks for the information. I've opened a new bug: https://youtrack.jetbrains.com/issue/IDEA-152321. Please follow it for updates.

Comment actions Permalink

Do you mean there is no checkbox to prevent it? This issue was fixed long time ago: https://youtrack.jetbrains.com/issue/IDEA-118296 .

0
Comment actions Permalink

Hi Serge,

 

Yes, that's exactly what I mean. Worth mentioning I am running El Capitan (10.11.3) and Intellij 15.0.4 (updated today, I did not try to disable App Nap before this update though so I don't know if the last patch has something to do with it or not) 

 

 

0
Comment actions Permalink

This is not fixed. The problem is still present in IntelliJ CE 2017.3. See https://youtrack.jetbrains.com/issue/IDEA-152321

0

Please sign in to leave a comment.