Console window at Grails Project open displays GC overhead limit exceeded errors

Answered

I have a large grails (2.3.7/jdk 1.7_80) project from a third party.  When I open it in IntelliJ, The console window displays the following messages for each of my plugins

WARNING: Inline plugins for [xxx.git] cannot be read due to error: GC overhead limit exceeded

and then goes on to say that Settings synchronization failed, although I can still build and run the project itself.

It looks like its automatically trying to run something called "idea-print-project-settings -plain-output". I'm pretty sure the problem is that the memory parameters in the command line are inadequate for a project of this size and I need to increase the PermSize and MaxPermSize, which are  -XX:MaxPermSize=256m -XX:PermSize=256m. In fact, if I run the same command at the command line, with updated memory settings, it works fine.  My  problem is I don't see where those are set for the IntelliJ console. They aren't the settings in the vmoptions file and they're not the vm settings for either the project or for the default grails settings. Does anyone have any suggestions as to how to change the settings and resolve this problem? 

p.s. On slightly smaller projects, I do not get the errors.

4 comments
Comment actions Permalink

There is one undocumented feature. 

Create grails-synch-jvm-options.txt file near your grails-app directory, and place your vm options there. 

We just had no time do implement GUI for this.

0
Comment actions Permalink

Excellent! That resolved the problem. Thank you very much!

0
Comment actions Permalink

Parabéns e obrigado! deu ótimo aqui! um abraço.

0

Please sign in to leave a comment.