Intellij Idea 15 - disable import statement re-arrangement

Answered

Hi, I'm using INtellij Idea 15 for my Java project. I notice that the IDe automatically updated my import statement arrangement. It did that in order specified in Settings > Editor > Code Style > Imports > Import Layout. I deleted all statements from there but now it re-arranges the imports in alphabetical order.

I do not want it to make any kind of arrangements on my import statements. How can I prevent Idea from ignoring my import statements for re-arrangements?

Thanks

4 comments
Comment actions Permalink

Disable this option:

0
Comment actions Permalink

@Serge Baranov that helps but it's not an actual solution. Occasionally I have unused imports and I manually invoke "Optimize imports" to remove them, but that also reorders them. It would be nice to be able to disable the reordering. 

1
Comment actions Permalink

I'm willing to go to the extra work despite the tracked issue. This works for me.

Thanks, Serge!

0

Please sign in to leave a comment.