JNI_CreateJavaVM failure on 2016.1

Answered

I'm currently unable to get the IDE to start with a new install of 2016.1. I just put it on today and at first it was able to get to the project selection screen. After a few seconds it found some updates and I went ahead and allowed them to happen. Afterwards it was recommended to restart the IDE, which I opted to do, but it never came back. It hasn't been back since.

running OS X 10.9.4 (13E28)

Seeing this in the system logs:

3/18/16 2:57:26.180 PM idea[1960]: Value of IDEA_JDK: (null)
3/18/16 2:57:26.185 PM idea[1960]: fullFileName is: /Applications/IntelliJ IDEA.app/Contents/bin/idea.vmoptions
3/18/16 2:57:26.186 PM idea[1960]: fullFileName exists: /Applications/IntelliJ IDEA.app/Contents/bin/idea.vmoptions
3/18/16 2:57:26.186 PM idea[1960]: Value of IDEA_VM_OPTIONS is (null)
3/18/16 2:57:26.186 PM idea[1960]: Processing VMOptions file at /Users/chris_uhl/Library/Preferences/IntelliJIdea2016.1/idea.vmoptions
3/18/16 2:57:26.186 PM idea[1960]: Done
3/18/16 2:57:26.191 PM idea[1960]: JNI_CreateJavaVM (/Applications/IntelliJ IDEA.app/Contents/jre/jdk) failed: 4294967290
3/18/16 2:57:26.192 PM com.apple.launchd.peruser.503[175]: (com.jetbrains.intellij.106336[1960]) Exited with code: 255

 

I've tried several things: adding an idea.jdk to the configuration to point at a separate VM (tried both 1.8.0_u40 and 1.8.0_u73). Same error. That error code coming out of JNI_CreateJavaVM seems a little suspicious.

I'm guessing this is a simple problem, but I'm kind of a newbie when it comes to troubleshooting IDEA. Anyone have any ideas?

 

 

3 comments

Please share the contents of `/Users/chris_uhl/Library/Preferences/IntelliJIdea2016.1/idea.vmoptions` file.

Then try to remove this file. Does it help?

0

Contents of indicated file:

 

-Xms500m
-Xmx2Gm
-XX:MaxPermSize=350m
-XX:ReservedCodeCacheSize=225m
-XX:+UseCompressedOops

 

(should be the defaults; I hadn't changed anything in there)

Removing the file got me back to the startup screen, so that's progress. Thanks!

 

0

-Xmx2Gm is not a valid option should be -Xmx2G instead.

0

Please sign in to leave a comment.