IntelliJ 16 breaks java classes

Answered

Hi! I was working perfectly well with IntelliJ IDEA 15, but today I decided to upgrade and I've regret that decision since the very morning. Errors like these:

  • Unknown Module Type. Cannot determine module type ("J2EE_WEB_MODULE") for the following module: "myproject". The module will be treated as Unknown module.
  • Error Loading Project. Cannot load facet Web (myproject)
  • I've some imports in my classes and now the IDE cannot find those libraries, which are included in a pom.xml (v 15 had no problem with this at all)
  • In the pom.xml I'm receiving a lot of errors that I wasn't before, like Dependency "x y z" not found, like Plugin "x y z" not found, and some like that, that previously wasn't there.
  • I keep working in what I was doing, and when I was going to make a Github push I saw to new "myproject.iws" and "myproject.ipr"

I want to use this new version, but honestly is annoying to see all those warnings and errors. I mean, I'm not compiling with the IDE because my project has an auto-compiler for all, but I'm sure that if I need to compile something from the IDE, I'll not be able to do it.

Also, I'm trying to download the previous version (if I can solve this issues quickly) but can't find it, can you send me a link to it?

Please help me, I really love IntelliJ, I've used versions 14 and 15 and I love them, I've used PHPStorm and WebStorm and I've also loved them, but this new version just broke my heart hahaha, HELP!

 

5 comments

It looks like you have generated your project using "mvn idea" command which is a legacy way not supported by JetBrains.

In case of a Maven project just open pom.xml file from the welcome screen and IDEA will import it correctly.

Delete .ipr/.iws legacy files.

0

Hi Serge,

I did what you suggested, but the problem persists :(

0

Please share a sample project to reproduce the problem.

0

I just found that IntelliJ 15 was still installed on my Mac, I opened my project with that version and everything works fine, so I'm assuming is something with the new version 2016.1 

I'll return to work with version 15, but will be great to fix 2016.1 if anybody know how :)

0

It's unlikely to be fixed if we can't reproduce it.

0

Please sign in to leave a comment.