Unable to install the package Pandas

Hello everyone,

I'm using PyCharm v2.6.3 on MAC OSX 10.7 (Lion) and want to install the Pandas package.  However, when I attempt this, the following error appears:

Install packages failed: Error occurred when installing package pandas.

The following command was executed:

/Applications/PyCharm.app/helpers/packaging_tool.py install –build-dir /private/var/folders/b2/7gvgmfj51q5btxl32jjnbc000000gn/T/pycharm-packaging3959663978265199507.tmp pandas

I've upgraded Numpy to version 1.6.2 since the previous fail required it.  However, subsequent attempts to install Pandas are still failing.  Any help on the issue would be appreciated.

Kind regards,
Paul
7 comments
Comment actions Permalink
Does it work if you execute 'pip install pandas' from the command line?
0
Comment actions Permalink
Hello Dmitry,

Many thanks for your response.

I tried to install from the terminal as suggested and the process failed:

pip install pandas
Downloading/unpacking pandas
  Downloading pandas-0.10.0.tar.gz (2.8MB): 2.8MB downloaded
  Running setup.py egg_info for package pandas
    pandas requires NumPy >= 1.6.1 due to datetime64 dependency
    Complete output from command python setup.py egg_info:
    pandas requires NumPy >= 1.6.1 due to datetime64 dependency


Command python setup.py egg_info failed with error code 1 in /var/folders/b2/7gvgmfj51q5btxl32jjnbc000000gn/T/pip-build/pandas
Storing complete log in /var/folders/b2/7gvgmfj51q5btxl32jjnbc000000gn/T/tmpw2XXBj
Virginias-iMac:QSTK virginia$ pip install pandas
Downloading/unpacking pandas
  Running setup.py egg_info for package pandas
    pandas requires NumPy >= 1.6.1 due to datetime64 dependency
    Complete output from command python setup.py egg_info:
    pandas requires NumPy >= 1.6.1 due to datetime64 dependency


Command python setup.py egg_info failed with error code 1 in /var/folders/b2/7gvgmfj51q5btxl32jjnbc000000gn/T/pip-build/pandas

I can send you the log file?

Kind regards
Paul
0
Comment actions Permalink
Could you please make sure that you installed the new numpy under the same Python interpreter in which you're trying to install pandas?
0
Comment actions Permalink
Thanks Dmitry.  This one appears to be solved now.  Paul
0
Comment actions Permalink

I have this problem too. Running PyCharm Community Edition 2017.2.3 on MacOS 10.12.6.

It should very easy to install pandas, as it is easy to install numpy. But it's not.

I have read many, many tips on online for solving this and none of them work.

I have gotten to the point where Pandas does show up as an available package in PyCharm under the Project Interpreter. Several times I have used that dialog to install pandas, and it reports that it succeeded.

But when attempting to run "import pandas as pd" in my program, PyCharm grays out that line and fails to import pandas. In previous runs I got an error explanation saying that byte compiles were disabled, but now I do not see any messages. I have followed tips in numerous posts about this byte compilation problem but that did not seem to help.

It is apparent that pandas did not import correctly, since "dataframe" is not recognized.

 

0
Comment actions Permalink

Hi 4am, do you use anaconda?

0
Comment actions Permalink

I do not use anaconda. However I did install it in an attempt to get pandas for PyCharm. It looks like that may be the problem. Now I am trying to figure out how to delete the libraries and packages that PyCharm cannot use, without damaging anything on my Mac.

0

Please sign in to leave a comment.