Oracle - Reading Schema never stopps

Hi,
I'm connecting to a large Oracle DB Server used for testing with about 20 custom schemas.
Each schema has 30+ tables and some of them are Production dumps.
The time that is needed for ODBE to load all schema information is really long, or getts stuck in the process. I've been working for about 30 min. on a given user and it didn't end.Only exiting from the application helps.

I had such issue sometime ago but can't recall the specific version.

I've got such a problem with the new version of 0xDBE (143.1301.4, not sure if there is any diffrence in the DataGrip version).

5 comments
Comment actions Permalink

Hi Marek,

Could you please check if it is better with the last version from https://www.jetbrains.com/datagrip/download/ ? How many schemas do you have selected in Schemas tab for the datasource?

Could you please also provide output from Test Connection button for the datasource,  several last idea.log files https://intellij-support.jetbrains.com/hc/en-us/articles/206827517 . Thanks.

0
Comment actions Permalink

When selecting an Oracle data source I have noticed a few things that significantly impact loading.

Are you by chance using TNS names?

Are you selecting any of the SYS tables from the schemas tab?

0
Comment actions Permalink

Hi, Sorry for the late response.
Going in to DataGrip ver 1.0.1, stopped the issue from poping, but yes I'm using the TNSNames to specify the connection details.

0
Comment actions Permalink
I'm encountering this problem quite frequent. I have several connections to different databases with 
the same schema names and objects (dev,test,prod), and quite often when I want to drill down into
ex packages, it will just not stop loading....

 

Anything I can do to avoid this?

0
Comment actions Permalink

Hi, try to update to the latest DataGrip version (2016.3). Thank you

0

Please sign in to leave a comment.