jetbrains products and git lfs question

Answered

My question pertains to all jetbrains IDEs (not just intelliJ).

Is it safe to pull/push from git lfs enabled repositories with intelliJ, webstorm, rubymine, etc. etc.

Is there any specific steps that anyone has tried for properly using with IntelliJ?

Thanks

 

 

7 comments

I don't think many people tried it, we don't have any related issues, though.

0

OK. Thanks.I'll experiment carefully at first ;->

If anything goes wrong, I'll file a support ticket right away.

Appreciate the quick response.

 

0

OK.. Things "seem" to work OK but sadly the UI needs a lot of work here.

A few notes..

After installation, git lfs commands work fine.

I tried something easy...

I added *.png to lfs 

The conventional way seems to be to create a .gitattributes.

*.png filter=lfs diff=lfs merge=lfs -text

git push seems to work correctly, but there are problems with the "Version Control / Local Changes" (the files do not show up there).

The logoAT.png shows in the tree view on the left and is accessible. The new PNG just doesn't show up in Version control view.

Not sure if there is something wrong, but it is very confusing as it appears that the PNG will not get pushed into the repo.

I did confirm, it does.. just intelliJ doesn't realize that it seems.

Here's a screen capture (I did this one from webstorm) (same issue in other IDEs).

Let me know if you want to try anything or if I should just leave alone for now. Feel free to move to webstorm if you like.

Since it's the same in all, expect it to be the same with a java app, etc.




0

Unfortunately, it gets worse.  The git push from Jetbrains did not work. The file is still left behind because it was not added (git add).

I had to go to a shell and do a git add public/images/logoAT.png externally .. 

After I did git add public/images/logoAT.png it shows up in my IDE to be pushed via the normal procedure.

So, it SORT of works if you shell out and manually add it first. Hope this helps other who are trying to get this to work.

 

 

0

I'm working through this on PyCharm.

I can get "Add to VCS" (git add) to work through PyCharm, but push does not work via PyCharm (2017.3.2).  It fails with:

Failed with error: failed to push some refs to 'https://github.com/myuser/myrepo.git'
0

@Will

 

Check the Console tab of the Version control toolwindow. What is the full error?

0

I have the same issue and the log messages are as shown below:

Caused by: java.lang.IllegalArgumentException: Illegal character in scheme name at index 0: "https://github.com/mysticfall/AlleyCat.git"
at java.net.URI.create(URI.java:852)
at com.microsoft.alm.common.utils.UrlHelper.createUri(UrlHelper.java:55)
at com.microsoft.alm.plugin.context.ServerContext.getKey(ServerContext.java:79)
at com.microsoft.alm.plugin.context.ServerContextManager.get(ServerContextManager.java:145)
at com.microsoft.alm.plugin.context.ServerContextManager.getBestAuthenticationInfo(ServerContextManager.java:456)
at com.microsoft.alm.plugin.idea.git.extensions.TfGitHttpAuthDataProvider.getAuthData(TfGitHttpAuthDataProvider.java:24)
at git4idea.commands.GitHttpGuiAuthenticator.findBestAuthData(GitHttpGuiAuthenticator.java:264)
at git4idea.commands.GitHttpGuiAuthenticator.askUsername(GitHttpGuiAuthenticator.java:149)
at git4idea.commands.GitHttpAuthService$InternalRequestHandlerDelegate.askUsername(GitHttpAuthService.java:63)
... 55 more
Caused by: java.net.URISyntaxException: Illegal character in scheme name at index 0: "https://github.com/mysticfall/AlleyCat.git"
at java.net.URI$Parser.fail(URI.java:2848)
at java.net.URI$Parser.checkChars(URI.java:3021)
at java.net.URI$Parser.checkChar(URI.java:3031)
at java.net.URI$Parser.parse(URI.java:3047)
at java.net.URI.<init>(URI.java:588)
at java.net.URI.create(URI.java:850)
... 63 more

I suspect this could be because IntelliJ (actually Rider, in my case) doesn't take into account a quoted URL, as my .git/config contains the following section:

[lfs "https://github.com/mysticfall/AlleyCat.git/info/lfs"] 
   access = basic
0

Please sign in to leave a comment.