Forced Soft Wrap in Active Editor Window

When opening a CSV file with long lines, the editor forces a soft wrap which is theoretically to improve readability. Forcing soft wraps appears to be default behavior for the IDE.

I can turn off the soft wrap in each file by unchecking View > Active Editor > Use Soft Wraps
I have soft wraps turned off by default in preferences by unchecking Preferences > Editor >  General > Use Soft Wraps in Editor

The forced soft wrap ignores my preferences.

Is it possible to stop the IDE from forcing soft wrapping? I despise this behavior. It radically reduces readability for me and is having a minor but noticible negative impact on my productivity.

Thank you,
-S

9 comments
Comment actions Permalink

Did you try to turn off soft wrapping in Settings -> Editor -> General -> Use soft wrap in editor ?

0
Comment actions Permalink

I'm in the same boat.  As the OP also stated, I have soft wraps disabled in Settings > General > Use soft wraps in editor, but opening files with long lines I get the message at the top "This document contains very long lines. Soft wraps were forcibly enabled to improve editor performance."  Only remedy appears to be the OP's strategy of disabling View > Active Editor > Use Soft Wraps in every single file which is less than desirable.

001.png

1
Comment actions Permalink

Same situation.

One workaround is to add 'editor.soft.wrap.force.limit=nnnnn' to idea.properties.

It is a serious readability issue for me too.

1
Comment actions Permalink

We have a corresponding request on our tracker, please vote for it:

https://youtrack.jetbrains.com/issue/IDEA-138523

0
Comment actions Permalink

Editing idea.properties is not really a solution because the file is overwritten at each update (which is also much more problematic for EAP users like me which receive ~1 update per week). Voted for the issue.

0
Comment actions Permalink

@Mark,

did you edit this file in /bin? If so then it's not recommended, you should modify a copy in user's home instead, please take a look:

https://intellij-support.jetbrains.com/hc/articles/206544869

0
Comment actions Permalink

Note: You can select 'Help' > 'Edit Custom Properties' to automatically create a new idea.properties file for your user, that should persist through updates.

However, IntelliJ keeps forgetting the wrap setting immediately. Every compare, every new file, it's definitely annoying and should be fixed.

1
Comment actions Permalink

In Line number column right click > un-checkt he Soft-Wrap [Current File | All Files]

 



7
Comment actions Permalink

News Versions:
Editor > General > Soft Wraps > Soft-wrap files: *

2

Please sign in to leave a comment.