Ctrl + Shift + . should give me: <%= %> but it doesn't

Rubymine 3.1 on Windows

In an erb-file: anyone know the keyboard shortcuts to generate "<%= %>" ?

In the demo vids, they say that Ctrl+Shift+. should do the trick, but on my end that does nothing. Can enyone enlighten me on this department? Is there anywhere I can find this information? I browsed the helpfile and het keymaps, but I can't seem to find anything that is related to this.

Thanks!

3 comments
Comment actions Permalink

Settings | Keymap | Main Menu | Tools | Extensions | Erb | Insert '<%= %>', default shortcut on Windows is Ctrl+Shift+Period (Ctrl+Shift+.)

Verified and works fine inside .erb files.

0
Comment actions Permalink

I appreciate the reply, now I can find the command in the settings.

Probably a regional thing:

On an AZERTY keyboard, the "." on the numeric pad, is in combination with 'shift', delete. So shift+. (on numeric pad) = Delete. So the shortcut for Ctrl+Shift+. is reduced to Ctrl+delete
On the alphanumeric (that's he big part with the letters, right) "." is in combination with 'shift', semicolen. So Shift+. (on alphanumeric) = ";". So the shortcut for Ctrl+shift+. (on alphanumeric side) is reduced to Ctrl+;

Bottom line: on my AZERTY keyboard, the Ctrl+Shift+. is never fired as far as the software is concerned.

I now remapped the key to Ctrl+Shift+% and this works fine for me. Thanks for the help!

-

By the way: it would be nice to have a way to insert "<% %>" as well. Can I configure this myself somehow?

0
Comment actions Permalink

By the way: it would be nice to have a way to insert "<% %>" as well. Can I configure this myself somehow?

You can implement it easily on ruby, see javascript:;. "<%= %>" action is described in the end of my post in "Editor actions" section.

0

Please sign in to leave a comment.