Error compiling plugin

I don't get it! Could this be because we are on a Friday afternoon? Ok, here it is: I am trying to recompile the code of my plugin with a recent RC of IDEA 5.0 and I am getting this error (both with Ant and Build / Make Project):

AutoFormatTextAction.java (154:37)cannot access com.intellij.openapi.extensions.AreaInstance

In that file, at the given line I don't have any error highlighted, and I am not using this AreaInstance class anywhere and I can't even find it in openapi.jar. So now, what's going on?

CommandProcessor.getInstance().executeCommand(project, new Runnable() {
public void run() {
ApplicationManager.getApplication().runWriteAction(new Runnable() {
public void run() {
selectionModel.setSelection(startPosition, endPosition);
EditorModificationUtil.insertStringAtCaret(editor, reformattedText, true, false);
selectionModel.setSelection(newCarretPosition, newCarretPosition);
editor.getCaretModel().moveToOffset(newCarretPosition);
}
});
}
}, null, null);

Alex

2 comments
Comment actions Permalink

Alessandro Vernet wrote:

I don't get it! Could this be because we are on a Friday afternoon? Ok, here it is: I am trying to recompile the code of my plugin with a recent RC of IDEA 5.0 and I am getting this error (both with Ant and Build / Make Project):

AutoFormatTextAction.java (154:37)cannot access com.intellij.openapi.extensions.AreaInstance


Make sure that you have added IDEA_HOME/lib/extensions.jar to your classpath. You should
also use the Plugin DevKit with a dedicated IDEA-JDK which will have this library added by
default.

HTH,
Sascha

0
Comment actions Permalink

That's it! Thank you Sascha.

Alex

0

Please sign in to leave a comment.