java.security.PrivilegedActionException: java.security.PrivilegedActionException: java.io.IOException: Cannot get content of directory

Answered

Hi

I am using IntelliJ Idea 15 CE
I am getting following error whenever i try to import a project
java.security.PrivilegedActionException: java.security.PrivilegedActionException: java.io.IOException: Cannot get content of directory

I have tried with Ultimate edition too and got the same error.

I have tried uninstalling plugins/restarting and stuffs but it didn't help to fix the problem.
I am not sure what changes to settings have caused this.


That said, opening the project still works

Below is the log



2016-01-09 00:05:23,473 [  65312]  ERROR - tartup.impl.StartupManagerImpl - IntelliJ IDEA 15.0.1  Build #IC-143.382.35
2016-01-09 00:05:23,473 [  65312]  ERROR - tartup.impl.StartupManagerImpl - JDK: 1.8.0_40-release
2016-01-09 00:05:23,474 [  65313]  ERROR - tartup.impl.StartupManagerImpl - VM: OpenJDK 64-Bit Server VM
2016-01-09 00:05:23,474 [  65313]  ERROR - tartup.impl.StartupManagerImpl - Vendor: JetBrains s.r.o
2016-01-09 00:05:23,474 [  65313]  ERROR - tartup.impl.StartupManagerImpl - OS: Mac OS X
2016-01-09 00:05:23,474 [  65313]  ERROR - tartup.impl.StartupManagerImpl - Last Action: ImportProject
2016-01-09 00:05:25,076 [  66915]   INFO -        com.atlassian.theplugin - Start: Project initializing
2016-01-09 00:05:25,146 [  66985]   INFO -        com.atlassian.theplugin - End: Project initialized
2016-01-09 00:05:25,992 [  67831]   INFO - lij.tasks.impl.TaskManagerImpl - Updating issues cache (every 20 min)
2016-01-09 00:06:28,607 [ 130446]  ERROR - llij.ide.plugins.PluginManager - null
java.security.PrivilegedActionException: java.security.PrivilegedActionException: java.io.IOException: Cannot get content of directory:  file:///XXXXXXXXXXXXX
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:721)
    at com.intellij.ide.IdeEventQueue.defaultDispatchEvent(IdeEventQueue.java:861)
    at com.intellij.ide.IdeEventQueue._dispatchEvent(IdeEventQueue.java:649)
    at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:380)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.security.PrivilegedActionException: java.io.IOException: Cannot get content of directory: file:///XXXXXXXXXXXXX
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:86)
    at java.awt.EventQueue$4.run(EventQueue.java:724)
    at java.awt.EventQueue$4.run(EventQueue.java:722)
    ... 12 more
Caused by: java.io.IOException: Cannot get content of directory:  file:///XXXXXXXXXXXXX
    at com.intellij.openapi.vfs.newvfs.impl.VirtualDirectoryImpl.contentsToByteArray(VirtualDirectoryImpl.java:414)
    at com.haskforce.importWizard.stack.StackProjectImportProvider.canImportFromFile(StackProjectImportProvider.scala:36)
    at com.haskforce.importWizard.stack.StackProjectImportProvider$$anonfun$canImport$2.apply(StackProjectImportProvider.scala:28)
    at com.haskforce.importWizard.stack.StackProjectImportProvider$$anonfun$canImport$2.apply(StackProjectImportProvider.scala:28)
    at scala.collection.IndexedSeqOptimized$class.prefixLengthImpl(IndexedSeqOptimized.scala:38)
    at scala.collection.IndexedSeqOptimized$class.exists(IndexedSeqOptimized.scala:46)
    at scala.collection.mutable.ArrayOps$ofRef.exists(ArrayOps.scala:186)
    at com.haskforce.importWizard.stack.StackProjectImportProvider.canImport(StackProjectImportProvider.scala:28)
    at com.intellij.ide.actions.ImportModuleAction$2.value(ImportModuleAction.java:185)
    at com.intellij.ide.actions.ImportModuleAction$2.value(ImportModuleAction.java:182)
    at com.intellij.util.containers.ContainerUtil.findAll(ContainerUtil.java:973)
    at com.intellij.util.containers.ContainerUtil.filter(ContainerUtil.java:947)
    at com.intellij.ide.actions.ImportModuleAction.createImportWizard(ImportModuleAction.java:182)
    at com.intellij.ide.actions.ImportModuleAction.selectFileAndCreateWizard(ImportModuleAction.java:136)
    at com.intellij.ide.actions.ImportModuleAction.selectFileAndCreateWizard(ImportModuleAction.java:115)
    at com.intellij.ide.actions.ImportModuleAction.doImport(ImportModuleAction.java:75)
    at com.intellij.ide.actions.ImportProjectAction.actionPerformed(ImportProjectAction.java:29)
    at com.intellij.openapi.actionSystem.ex.ActionUtil.performActionDumbAware(ActionUtil.java:182)
    at com.intellij.openapi.actionSystem.impl.ActionMenuItem$ActionTransmitter$1.run(ActionMenuItem.java:311)
    at com.intellij.openapi.wm.impl.FocusManagerImpl.runOnOwnContext(FocusManagerImpl.java:958)
    at com.intellij.openapi.wm.impl.IdeFocusManagerImpl.runOnOwnContext(IdeFocusManagerImpl.java:124)
    at com.intellij.openapi.actionSystem.impl.ActionMenuItem$ActionTransmitter.actionPerformed(ActionMenuItem.java:281)
    at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
    at com.intellij.openapi.actionSystem.impl.ActionMenuItem.fireActionPerformed(ActionMenuItem.java:109)
    at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2346)
    at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
    at javax.swing.JToggleButton$ToggleButtonModel.setPressed(JToggleButton.java:308)
    at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
    at com.apple.laf.ScreenMenuItemCheckbox.itemStateChanged(ScreenMenuItemCheckbox.java:193)
    at java.awt.CheckboxMenuItem.processItemEvent(CheckboxMenuItem.java:389)
    at java.awt.CheckboxMenuItem.processEvent(CheckboxMenuItem.java:357)
    at java.awt.MenuComponent.dispatchEventImpl(MenuComponent.java:351)
    at java.awt.MenuComponent.dispatchEvent(MenuComponent.java:339)
    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:754)
    at java.awt.EventQueue.access$500(EventQueue.java:97)
    at java.awt.EventQueue$3.run(EventQueue.java:702)
    at java.awt.EventQueue$3.run(EventQueue.java:696)
    ... 17 more
2016-01-09 00:06:28,608 [ 130447]  ERROR - llij.ide.plugins.PluginManager - IntelliJ IDEA 15.0.1  Build #IC-143.382.35
2016-01-09 00:06:28,608 [ 130447]  ERROR - llij.ide.plugins.PluginManager - JDK: 1.8.0_40-release
2016-01-09 00:06:28,608 [ 130447]  ERROR - llij.ide.plugins.PluginManager - VM: OpenJDK 64-Bit Server VM
2016-01-09 00:06:28,608 [ 130447]  ERROR - llij.ide.plugins.PluginManager - Vendor: JetBrains s.r.o
2016-01-09 00:06:28,608 [ 130447]  ERROR - llij.ide.plugins.PluginManager - OS: Mac OS X
2016-01-09 00:06:28,608 [ 130447]  ERROR - llij.ide.plugins.PluginManager - Last Action: ImportProject



Thanks & Regards
Anil

9 comments
Comment actions Permalink

What's the path it can't access?

0
Comment actions Permalink

Basically any path that has my project

/Users/Anil/Src/activator/reactive-stocks


2016-01-09 02:44:39,354 [9621193]  ERROR - llij.ide.plugins.PluginManager - null
java.security.PrivilegedActionException: java.security.PrivilegedActionException: java.io.IOException: Cannot get content of directory: file:///Users/Anil/Src/activator/reactive-stocks/app

0
Comment actions Permalink

Does /Users/Anil/Src/activator/reactive-stocks/app belong to the current user?

0
Comment actions Permalink

Yes. Directory belongs to current user
Inetead of "New => Project from Existing Sources..." if do "Open" it works.

It used to work just fine for a long time.
Then it stopped working few days back. I Ignored it assuming it is due to opening too many projects. (I Used "Open" as a work around)


Consistantly reproducible for me .
It is happening on Ultimate Edition too, (I installed it today). So not sure If any sort of file permissions issue. But I have never done any such permission settings for CE too


Version Info
Screen Shot 2016-01-09 at 3.05.58 am.pngScreen Shot 2016-01-09 at 3.05.41 am.png

0
Comment actions Permalink

Please send the contents of the directory you are trying to import to support (https://intellij-support.jetbrains.com/hc/).

Also attach the complete idea.log (https://intellij-support.jetbrains.com/hc/articles/207241085) and `ls -lR` output for the project directory that you are trying to import.

0
Comment actions Permalink

Attached are the ls -lR output and idea.log files



Attachment(s):
idea.log.zip
ls-lR.txt.zip
0
Comment actions Permalink

It uses /Users/8202/Src/activator/reactive-stocks/app path, not /Users/Anil/Src/activator/reactive-stocks/app as you have specified before.

ls shows that files are owned by MYNT\Domain Users, and not 0802 or Anil user.

Also, SBT seems to run on Java 1.6 when importing causing several exceptions, make sure to use Java 8.

0
Comment actions Permalink

Serge,

I had manually changed 8202 to Anil while posting it here as i wanted to avoid posting my employee Id:|
The real path was 8202.

Update.
After a machine restart and some gradle syncs on ther projects this has started working fine on ultimate edittion
However, i still do get the same error of CE15.

I will check on SBT and Java mismatch issue.

0
Comment actions Permalink

Hi Anil,

I am also facing the same issue. Can you guide me how you resolved this issue?

0

Please sign in to leave a comment.