IntelliJ IDEA CE build 142.3553.1, -DHidpi=true not working

Hi,

I'm using Debian stretch x64 with Gnome 3.16 on a 27" screenw ith 4k resolution. Scaling with IntelliJ IDEA was perfect when enabling -DHidpi=true in vmoptions until release 142.3553.1.
The changelog reports: "True HiDPI support for Windows and Linux". It is used to work without any additional setup, but for me it doesn't. Menu text scaling is fine, but icons and editor fonts are too small. I can change the editor font of course, but how can I scale the icons in the newest build?

Best regards,
Frederik

3 comments
Comment actions Permalink

Please wait for the next EAP.

0
Comment actions Permalink

Similar setup: EAP 142.3553.1: gnome 3.16.2 (arch) on a 2560x1440 thinkpad carbon X1G3

I didn't set the -DHidpi setting like I used to - everything renders at "native" resolution.

So - I invoked
    xrandr --dpi 192
to hint to IJ how to run things and then everything looks perfect.

However... that confuses all the other gnome apps... they all now run at "native" mode.


I did try on an ubuntu 15 image, with the display scale slider set to 2x - IJ works perfectly, as do all the other HiDPI apps.

0
Comment actions Permalink

All Gnome problems resolved in 142.3728.3

0

Please sign in to leave a comment.