How to remove this annoying feature in IntelliJ IDEA?

Answered

Hello everyone,
I have been using IntelliJ for a bit over 6 months and I have noticed something very annoying. I don't really know how to explain it but it happens every time I create a getter, take a look at this screenshot: http://prntscr.com/9lizo4
Is it possible to remove this so that the lines are correct and it looks like this instead?: http://prntscr.com/9lj16z

Thank you people!

2 comments
Comment actions Permalink

This is called code folding.

You can disable automatic folding in the settings:
Settings -> Editor -> General -> Code folding , disable the "One line methods" option in the "Collapse by default" section.

Regards,
Wallaby

2
Comment actions Permalink

Simple property accessors folding also needs to be disabled.

1

Please sign in to leave a comment.