Disable checking incoming and outgoing changes

I almost always see the spinning loading icon with the message "Checking incoming and outgoing changes" in the bottom of IDE. I think it is happening because my repository is unreachable unless I connect VPN, and it's trying to update my repository, times out or something, and trying it again and again, and I'm quite annoed by the spinning annimation. I would like to check changes only when I need to.

I tried to follow suggestions from this stackoverflow post, but it seems the interfaces has changed a lot since then.
http://stackoverflow.com/questions/18958877/how-do-i-stop-intellij-searching-for-incoming-svn-changes

So any suggestions how I can disable checking incoming and outgoing changes?
Also the problem appeared when I upgraded to IDEA 15.

5 comments
Comment actions Permalink

There is a comment about Settings | Version Control | Background:

http://i.imgur.com/DdEPAZH.png

Still the same in 15.0.2.

0
Comment actions Permalink

Do you use Mercurial VCS?

0
Comment actions Permalink

Konstantin, do you think it's related to Mercurial?

0
Comment actions Permalink

Serge, I have unchecked the checkbox "Refresh changes every N minutes", but it's still trying to check incoming changes.

0
Comment actions Permalink

There is "Check for incoming and outgoing changesets" checkbox in "Mercurial" settings. If you use Mercurial and it is checked, the task you mentioned should be invoked as part of Mercurial plugin logic and you could disable it by unchecking the checkbox. Otherwise settings mentioned by Sergey should be relevant.

1

Please sign in to leave a comment.