Git not working

I'm using IntelliJ Idea 14.1.4, I've created a project and working on my code, I enabled Git integration for the project and initialised my local git repository. Each time I select push or checkin it says there are no changes, which is nuts because there are hundreds of changes in a whole pile of files.

I followed the steps in HELP but it never picks up any changes, clearly I am missing something simple but I'm not sure what. This is the first time I have tried using git in Idea as I usually use SmartGit externally.

Thanks for any ideas!



Just for a datapoint, Git integration works for me so far. Is there any other indicator that the file you know is changed is not a part of the Git project, for example on my WIn 7 system, the color of the filename in the tab and project view changes from black to blue when Git "knows" about the file. I am thinking the files you think are in Git are not for some reason.


Thanks JD.  I notice I have no icons on the files in the project, only on project name itself. I tried adding the files themselves but the "+ add file" menu option is greyed out.


Make sure you have the correct git root folder specified in Settings | Version Control.


Thank goodness I am not alone! I am rather uniquely experiencing this problem on my laptop but not on my desktop. I am using the same version of IDEA (14.1.4) on both systems, the same version of Windows 7 64bit, the same version of git. On my desktop everything is flawless. On the laptop, Git's recognition of changes is spastic and bizarre. When I load a project freshly, everything is right, but as soon as I make changes, there's about a 50% chance (seriously, I can't find any common causes) that the change will be recognized (i.e. gutter marks blue). If it's not recognized, git loses the entire file. Every change that is known in the file is lost and the filename turns white, as though Git never existed for that file. Once this happens that file is lost and changes will never be recognized--until of course I close and reopen the project, at which point I assume it scans anew and notices the changes.


What do you mean by "git loses the entire file"? Does the file content change in the IDE? Does the file content change on disk (check from some external problem like Far)?
Also check if your git repository and/or working tree are located on the same local drive, or something is on a network mount?


The issue seems to have resolved itself however I've recently upgraded to IDEA 15 Ultimate from 14.1.4 but I've also upgraded from Windows 7 64Bit to Windows 10 64Bit, this is the same physical machine but the very same project so I really have no idea of the root cause.


Please sign in to leave a comment.