License activation fails with SignatureException: Signature does not match

Answered

Just upgraded to v14 (.224)

However, after I enter my user/pass to validate my student license and hit OK I get:
JetProfile connection error: SSLHandshakeException: java.security.cert.CertificateException: java.security.SignatureException: Signature does not match.

How do I resolve this?

11 comments
Comment actions Permalink

Did you find a solution?  I hit the same error.

0
Comment actions Permalink

Ditto. Same error, dagnabit.

0
Comment actions Permalink

Hello.

Could you create an issue in our tracker: https://youtrack.jetbrains.com/issues/IDEA ?

We cannot reproduce the case in our environment, and for many users this type of licenses works. So, it's a problem in some specific environments.

The error message is quite plain: it means that IDEA for any reason cannot verify a certificate that comes from JetBrains license service site. Since IDEA build is identical for many users, and service site is the same for all them, it may mean some network problems, but we can't yet figure out, what problem. Please, file an issue to track it properly.

Thank you,
Alexander.

0
Comment actions Permalink

@Alexander,

I am experiencing the same error and created https://youtrack.jetbrains.com/issue/IDEA-134220

0
Comment actions Permalink

I had a similar issue when activating my PyCharm with user account on Mac. The problem turned out to be related to jdk 1.6. You can use Activity Monitor to inspect PyCharm and found which jdk is being used on Open Files and Ports.
To change it, edit /Applications/PyCharm.app/Contents/Info.plist, search for JVMVersion, change its value from 1.6*,1.7+ to 1.7+
In my case, I have jdk 8 installed on my Mac and it worked.

0
Comment actions Permalink

Getting same error.

0
Comment actions Permalink

Your solution worked for PhpStorm also, Thanks :)

0
Comment actions Permalink

I was having this on ubuntu, and changing the JDK to run on 1.7 definately worked for me.

I am actually using a modified jdk1.8 (the tuxjdk mod) to get improved font rendering, which I have selected directly by editing the bin/idea.sh script and setting the IDEA_JDK variable directly.

To get passed the license restriction (I upgraded to Intellij15 today) I commented out that line, ran it once with the default openjdk1.7 on the system, let it do all the license server checks, then shut it down and uncommented the java1.8 jdk variable and restarted.

I'm not 100% sure what is going on there as while it was resolved by using openjdk 1.7, it wasn't resolved by using oracle 1.8, so it might be more of an openjdk vs oracle thing than a 1.6 vs 1.7+ thing... i'll look into it more later.

Cheers

0
Comment actions Permalink

I had this issue and it seems that because I was also running eclipse which was using the JVM/JDK in the background, I was getting this error.  Once I closed anything that was using Java it went through finally. 

0
Comment actions Permalink

I'm having this issue and I'm not running Eclipse.

 

Having it with both Intellij and Webstorm.

0
Comment actions Permalink

The issue is likely caused by the self signed certificate used by your proxy. Contact your IT/security team for help. If it's the case, you may need to install the root CA into the JVM used to run the IDE. See https://intellij-support.jetbrains.com/hc/en-us/community/posts/115000094584-IDEA-Ultimate-2016-3-4-throwing-unable-to-find-valid-certification-path-to-requested-target-when-trying-to-refresh-gradle?page=1#community_comment_115000405564.

1

Please sign in to leave a comment.