Overriding user.name in file idea64.vmoptions when value contains spaces

How can I override property user.name in file idea64.vmoptions with a value that contains spaces?

Example:

-Duser.name=John Doe

Tried / doesn't work:

-Duser.name="John Doe"
-Duser.name=John\ Doe
-Duser.name="\"John Doe\""
... and more combinations, but none worked ...

Maybe there is another way to accomplish what I need:

Actually I'm trying to override the global settings for the username which is used in templates and/or autocompletion. For example in java sources the autocompletion may help to fill out @author fields ...

3 comments
Comment actions Permalink

btw, running the community edition (latest version) with the embedded java version on Ubuntu 14.04 ...

0
Comment actions Permalink

Are you sure IDEA is running under 64-bit JDK? Check idea.log to see which JDK is used and what options are loaded (https://intellij-support.jetbrains.com/entries/23352446).

0
Comment actions Permalink

Yes, I'm sure. I have traced the problem back to idea.sh and how variable substitution happens there (especially at the very bottom of the script). As far as I have seen there is no simple fix.

The only solution I have found is to rewrite idea.sh to assemble the final command as own string and use eval to execute it (instead of letting the shell directly execute it).

0

Please sign in to leave a comment.